1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

s3 issues help

s3ben19 Jan 13, 2011

  1. s3ben19

    s3ben19 New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    hi there bought my s3 about a month ago,
    and i have been have what i think are boost issues,
    i cant find any splits on any pipes,
    i have tried 3 different air mass sensors,

    if you are drivin normally it feels fine, but then when you boot it intially takes off but then feels to jus go flat until i ease off then feather the throttle ,

    any one have any ideas?

    many thanks ben
     
  2. Dane

    Dane Had an 8L S3, a B5 RS4 now I have a B8 S4

    Messages:
    4,062
    Likes Received:
    162
    Trophy Points:
    63
    I had something like this the other day but its gone now, have you had it scanned for faultcodes?
     
  3. s3dave

    s3dave TFSI Hybrid Supporter

    Messages:
    10,110
    Likes Received:
    736
    Trophy Points:
    38
    Have you looked at the turbo to charge pipe? if there is greasy oil on the orange pipe? they can work loose
     
  4. s3ben19

    s3ben19 New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    yeah i had it scanned a few times and it keeps comin up with air mass sensor, and summit to do with bank 2 summit or other can't rember fully ,
    yeah i have cleaned that pipe,
    its doing my head in now i really am stuck ?
     
  5. s3dave

    s3dave TFSI Hybrid Supporter

    Messages:
    10,110
    Likes Received:
    736
    Trophy Points:
    38
    bank 2 is usually something to do with lambda sensor
     
  6. s3ben19

    s3ben19 New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    its all good i've fixed it ,
    now got a healthy 250 bhp,
    the fuel presssure regulator pipe had come off,
     
  7. beachbuggy

    beachbuggy Well-Known Member

    Messages:
    1,929
    Likes Received:
    197
    Trophy Points:
    63
    have you checked the fuel pressure regulator piping?
     
  8. beachbuggy

    beachbuggy Well-Known Member

    Messages:
    1,929
    Likes Received:
    197
    Trophy Points:
    63
    Ahh see you beat me too it!! Oh well glad you found the answer.
     
  9. s3ben19

    s3ben19 New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    thanks for your help cheers
     

Share This Page