1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

S3 Engine tempreture not stable. Anyone got a clue? Tried changing the thermostate.

Discussion in 'A3/S3 Forum (8L Chassis)' started by Karliboy, May 23, 2010.

  1. Karliboy
    Offline

    Karliboy New Member

    Joined:
    May 23, 2010
    Messages:
    2
    Likes Received:
    0
    [May 23, 2010]
    Ok here`s the thing.

    For some time ago the waterpump broke and it almost ruined the damn car.
    We desembled the register and waterpump and it wasen`t much left of the blades on the waterpump. So we flushed the engine trying to get out as much of the blade peaces we could before we re-esembled the new parts. Filled up cooling fluid and checked for air in the system.
    Then we re-esembled the new register/waterpump and the car runs fine and have been for some months, and i guess if there was some air in the system it would have got out by now.:keule:

    The problem now is that the tempreture is not stable at 90¤C. When i drive it drops to about 70 - 80¤C and when i drive downhill for awhile it almost sinks to 60¤C. If i stop the car to a running stand still the tempreture climbes to 90¤C and stays there until i start driving again. It never goes over 90¤C

    I have changed the thermostate that is located close to the airfilter, if you guys know where that is but that didn`t help. Does anyone know whats wrong?

    Sorry for the bad english but hey im from Norway.:whistle2:
    #1
  2. Sandip
    Offline

    Sandip Well-Known Member

    Joined:
    Nov 7, 2006
    Messages:
    2,415
    Likes Received:
    74
    [May 23, 2010]
    I think what you have changed is the Temp sender, the thermostat is more near the alternator. It's your thermostat what needs changing:)
    #2
  3. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,660
    Likes Received:
    103
    [May 23, 2010]
    #3
  4. finesse
    Offline

    finesse Active Member VCDS Map User

    Joined:
    Aug 15, 2006
    Messages:
    2,811
    Likes Received:
    10
    [May 23, 2010]
    #4
  5. Andy´
    Offline

    Andy´ Member

    Joined:
    Nov 28, 2009
    Messages:
    52
    Likes Received:
    0
    [May 23, 2010]
    I did send you a PM Karliboy...
    #5
  6. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    120
    [May 24, 2010]
    Thats classic thermo failue symptoms. End of discussion.... LOL.
    #6
  7. Karliboy
    Offline

    Karliboy New Member

    Joined:
    May 23, 2010
    Messages:
    2
    Likes Received:
    0
    [May 24, 2010]
    Thanks for the help guys!
    #7

Share This Page