1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

S3 D.I.S just died

vanilla_ice Oct 5, 2006

  1. vanilla_ice

    vanilla_ice Member

    692
    21
    18
    HELP!

    Just filled up with petrol this morning and like to reset the trip and MPG on the computer. The last time I filled up the D.I.S screen went completely blank for a few seconds and then came back and worked as normal. Today however, it went blank and has no stayed blank.

    If i press the left stalk it still displays the miles until next service and completes the check with an "OK", but the screen then turns off again.

    Is there anything I can do to revive the display? I have heard getting D.I.S issues repaired can be costly :crying:

    Any advice greatfully received.

    Cheers,

    ICE
     
  2. s3shabs

    s3shabs Member

    155
    0
    16
    there should be a button underneath the right stalk which switches the dis on and off..
    try that. I dont think its faulty if it initially powers up. happened to me a few times until i realised there was a switch for it.
    hope this resolves your problem.
    shabs
     
  3. vanilla_ice

    vanilla_ice Member

    692
    21
    18
    Thats the button I use to reset the MPG. Maybe the switch is faulty - I'll go try.

    Thanks,

    ICE
     
  4. vanilla_ice

    vanilla_ice Member

    692
    21
    18
    Panic over!

    Thanks s3shabs!!!! I didn't realise if you pressed it quickly it turned the DIS on and off and if you held it, it resets the MPG etc.

    Thanks again,

    ICE :blush:
     
  5. Tallpaul

    Tallpaul Member

    835
    0
    16
  6. s3shabs

    s3shabs Member

    155
    0
    16
    Your welcome mate..
     
  7. Adams3

    Adams3 Member

    425
    2
    16
    I only found out about that from JoJo at inters!!

    Maybe i should :rtfm: !!!!!!!! lol
     

Share This Page