1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

S3 Brake Problem

Discussion in 'A3/S3 Forum (8L Chassis)' started by DavyJam, May 27, 2007.

  1. DavyJam

    DavyJam New Member

    Joined:
    Jan 18, 2007
    Messages:
    8
    Likes Received:
    0
    Just wondering if anyone has experienced this before, the car I have is a 2001 S3. Basically my brakes appear to not be working correctly, luckily the problem only started happening when i was about 200 yards from home.

    Symptoms are that the brake pedal can now be pressed right to the floor and it is only then that the brakes start to work, but no where near as efficiently as they where doing. No brake related warning lights come on the dash, but the ESP warning light comes on and stays on as soon as the pedal is pressed.

    Had the car serviced December 2006, all the brake pads, disks, etc where replaced and everything has been fine for last 6 months.

    I'm obviously stuck for getting this looked at today/tomorrow, just wondering if anyone has any ideas as to what the cause could be?
     
  2. Advert Guest Advertisement


  3. edward_harris

    edward_harris s3 gone now a shiney red evo 6

    Joined:
    Jan 11, 2007
    Messages:
    1,061
    Likes Received:
    2
    have you checked the fluid level?
     
  4. DavyJam

    DavyJam New Member

    Joined:
    Jan 18, 2007
    Messages:
    8
    Likes Received:
    0
    I did take the cap off and check the fluid and it seems fine.
     

Share This Page