1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

s3 8l facelift driving me crazy! ABS and ESP lights

Discussion in 'A3/S3 Forum (8L Chassis)' started by baconsworld, Apr 13, 2012.

  1. baconsworld
    Offline

    baconsworld New Member

    Joined:
    Apr 12, 2012
    Messages:
    4
    Likes Received:
    0
    Hello and i would really appreciate some help with this problem!
    when i got my s3 the abs light and the esp were both lit up.
    fault code points to longditudinal sensor.
    ok, so here it is, i have changed the londitudinal sensor and the lateral sensor and the abs module, have had the wiring checked, the basic settings reset and reset and all manor of diagnostics, i have got not a clue what to do next other than get rid of the car.
    The only thing i will say is, if anyone has any ideas or wants to take a look at the car for me it would be most appreciated. or if anyone can point me in the direction of a good abs specialist in the london area.
    thanks very much
    car is a 2001 s3 facelift.
    #1
  2. thegoal007
    Offline

    thegoal007 Another S3 owner....

    Joined:
    Apr 9, 2008
    Messages:
    733
    Likes Received:
    11
    doesn't the haldex controller have a part to play ?
    #2
  3. Grazam
    Offline

    Grazam Member

    Joined:
    Nov 13, 2011
    Messages:
    191
    Likes Received:
    2
    it was the wheel speed sensor on mine that gave me the same problems this is easily checked with vag com or at a garage with vag com as you can select the module and it should come up with individual wheel speeds as you spin each wheel by hand. The cable was at fault on mine so just one more thing to look at.
    #3
  4. baconsworld
    Offline

    baconsworld New Member

    Joined:
    Apr 12, 2012
    Messages:
    4
    Likes Received:
    0
    the fault code i cant get rid of is 01279 longitudinal acceleration sender g251 electrical fault in current circuit.
    another one comes an goes 01279 longitudinal acceleration sender g251 sporadic implausible signal.
    A
    #4
  5. thegoal007
    Offline

    thegoal007 Another S3 owner....

    Joined:
    Apr 9, 2008
    Messages:
    733
    Likes Received:
    11
    just so that we understand it corectly, you were getting all these errors before and after you replaced the londitudinal sensor and the lateral sensor and the abs module.
    very strange. I presume these were new parts ?
    the wheel speed sensor checks are also ones to try as advised above because although strictly speaking none of them are showing as faulty on vagcom - they may just be giving you an incorrect reading which may be causing your issues.

    NB. That abs module is like super expensive, a £1000 part (new).
    #5
  6. daz-20vt
    Online

    daz-20vt Well-Known Member

    Joined:
    Feb 6, 2012
    Messages:
    1,333
    Likes Received:
    138
    I had this exact issue a few years ago and nothing would clear it then one day i was playing with the longitudinal sensor while watching the value readings on vagcom and it kept going from 0-20 approx in the blink of an eye. I pushed the sensor a little harder and it wasnt plugged in crrectly. I know that sounds daft but i never touched it before it starting playing up so who knows why it happened but try the same if you have vagcom. You can get a much better idea if the car is static and its values change. And the guys are right wheel speed sensors are somehow linked so can through dodgy fault codes. You really need to study vagcom values not keep buying bits. It took 4 garages 4 new diferent sorts of sensor and £600 for me to fix it after picking the car up from the last garage that failed to fix it. Keep posting as much info as pos!! daz
    #6
  7. S3_Olly
    Offline

    S3_Olly Full Throttle

    Joined:
    Jul 22, 2011
    Messages:
    171
    Likes Received:
    0
    Hi mate im having the same issues at the minute and apparently mine is a G60 relay 90 or something so just waiting for the garage to get hold of that.
    i have just bought off ebay the the longitudinal and latitudinal sensors off ebay just in case, but cant find the one behind the glovebox if you happen to know where that is lol. they dont make things easy to get to do they but yes let me know how you get on as it sounds exactly the same as mine.

    cheers Olly
    #7
  8. daz-20vt
    Online

    daz-20vt Well-Known Member

    Joined:
    Feb 6, 2012
    Messages:
    1,333
    Likes Received:
    138
    Hi olly. I spent ages searching for this too. If my memory serves me correct and hopefully it does. The pre facelift is behind the glovebox the facelift is under the steering colomn. If its the glove box option its no hidden to well so should be obvious. You taking it fully out mate? Daz by the way i fixed mine years ago through searchin on here. There was a good guide. Ill try to find it for you!!
    #8
  9. S3_Olly
    Offline

    S3_Olly Full Throttle

    Joined:
    Jul 22, 2011
    Messages:
    171
    Likes Received:
    0
    Hi DAZ, mine is the audi s3 8l Facelift but there is that many people saying where they are that i just bought a **** load of sensors and thought id try my luck at finding them lol but to no joy at the minute.
    i belive that the tech that had a look at mine a while ago said it was a G60 Relay 90 or something but not 100% sure if thats right, i Could live with it but i dont think the MOT new regs would agree with that plus its just more annoying than anything.
    if you have some sort of diagram or know where these are that would be a great help.

    here are the quick links just to show you the ones that i have got .....

    2001 AUDI VW SEAT 1.8T ACCELERATOR SENSOR VAG 1J0907651A | eBay

    AUDI VW PASSAT MK6 BOSCH YAW ESP TURN ACCELRATOR SENSOR 8E0 907 637 A 8E0907637A | eBay
    VW SEAT SKODA AUDI GOLF MK4 YAW RATE SENSOR 1J0 907 657B / 1J2 907 637B | eBay

    Cheers Olly
    #9
  10. daz-20vt
    Online

    daz-20vt Well-Known Member

    Joined:
    Feb 6, 2012
    Messages:
    1,333
    Likes Received:
    138
    What codes are you getting up?
    #10
  11. superkarl
    Offline

    superkarl MAN OF STEEL

    Joined:
    Mar 28, 2010
    Messages:
    7,556
    Likes Received:
    1,077
    on my car, longitudinal behind glovebox, lateral under steering column. unplugging one or the other and checking with VCDS will confirm which is which. i first thought, and many people told me, it was the other way round, until i replaced the steering column one and nothing happened, then i worked it out.
    i literally plugged mine in and the fault never appeared again.

    p.s. i have a part number if needed, and a price which is many many monies. it think the two sensors are identical, just mounted differently so they read in the directions they do in VCDS.
    #11
  12. daz-20vt
    Online

    daz-20vt Well-Known Member

    Joined:
    Feb 6, 2012
    Messages:
    1,333
    Likes Received:
    138

    I think your right mate. It was such a long time ago im struggling to remember. But one of the sensors i thought changed position between pre and facelift. I may be wrong. But it was such a strezsful issue i feel for these guys. The sensors are the same im sure. Vagcom readings are crucial to solving this imo.
    #12
  13. baconsworld
    Offline

    baconsworld New Member

    Joined:
    Apr 12, 2012
    Messages:
    4
    Likes Received:
    0
    ok, here goes, the controller pn, 8n0-907-379-e Replaced at a cost of £1125 inc vat. longitudinal sensor changed cost £410, lateral sensor changed £144. Auto electrician £75 to check wiring ............. STILL THE SAME CODE
    Are there any ABS brake SPECIALISTS around?
    Thanks
    #13
  14. baconsworld
    Offline

    baconsworld New Member

    Joined:
    Apr 12, 2012
    Messages:
    4
    Likes Received:
    0
    Sorry, forgot to say. the facelift sensors are on a bracket attached to the steering column. the top one is longitudinal and the lower one is the lateral sensor.
    when i check my values on vag-com, the longitudinal os -7.68 after basic settings which is wrong value. it should be -1.5 to +1.5 but it wont go there no matter what i try. Changing the controller did make some difference though, before the car was always in 2wd but now its 4wd all the time, so on a tight turn the wheels seem to grip a lot too much.
    #14
  15. daz-20vt
    Online

    daz-20vt Well-Known Member

    Joined:
    Feb 6, 2012
    Messages:
    1,333
    Likes Received:
    138
    What happens when you play with the wires. Try moving them around to see if its a break. Dont go too rough and break it. Does it stay at that value or fluctuate. just play around while keeping an eye on it. Check the connections are clean etc. Have you check wheel speed sensor values
    #15
  16. MikeA3
    Offline

    MikeA3 Active Member

    Joined:
    Mar 21, 2005
    Messages:
    1,178
    Likes Received:
    1
    The longitudinal is behind the glove box on the facelift s3 - you can (just) get to it by removing he side panel but taking the glove box off is a 5 min job and makes access a lot easier.
    Both the sensors (long and lat) are the same part number so I'd start by swapping them over and rescanning the car.

    The lateral is on the steering column together with another sensor held in place with a gold colour bracket.

    Im not local (Epsom) but happy to help if you get stuck

    Mike
    #16
  17. Chlippo
    Offline

    Chlippo Member

    Joined:
    Apr 17, 2010
    Messages:
    671
    Likes Received:
    12
    I am facing a similar problem,
    -error 01279 Longitudinal acceleration sensor (G251) Implausible signal
    -error 00285 ABS Wheel speed sensor: Front Right (G45)
    Then again
    -error 00285 ABS Wheel speed sensor: Front Right (G45) Signal outside tolerance.

    Any ideas?

    And also what are the part numbers i need here (TT or S3 since no S3 here in Canada/USA)
    I found these two for the longitudinal sensor 1j1907638b and 1j0907651a...The price isnt the same thou...
    Last edited: Nov 8, 2012
    #17
  18. mcpickering
    Offline

    mcpickering Member

    Joined:
    Nov 30, 2011
    Messages:
    138
    Likes Received:
    2
    hey guys.

    having this issue too. however the fault that came up was the brake light sensor switch. So we replaced that with a brand new (genuine) one and the lights came on again on the way home. Very confused as this was the only fault that came up.

    It came up in 2 places on the ECU (can't remember where) and alex at Storm developments fitted the new sensor then cleared the faults.

    any ideas?

    James
    #18
  19. Kuvi-S3
    Offline

    Kuvi-S3 Member

    Joined:
    Apr 22, 2013
    Messages:
    168
    Likes Received:
    38
    Im having the same problem with my car at the moment. 2002 8L S3 AMK. I also see that the ESP light flashed every now and then and kills the power. Any ideas?
    #19

Share This Page