1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

S2 Overboost Problem

Discussion in 'S2/RS2 Forum' started by sss222, Feb 20, 2004.

  1. sss222
    Offline

    sss222 New Member

    Joined:
    Feb 20, 2004
    Messages:
    1
    Likes Received:
    0
    [Feb 20, 2004]
    Hi,
    I have a 1993 S2 6 speed which is awesome but because of a hugely annoying intermittent problem I am at the end of my tether with it. Basically under hard acceleration the car is liable to lose all power for a split second. Once this has happened the first time it will happen again with the slightest boost. If I switch the car off and start up again it may be fine for another few weeks!!! It always seems to happen when I really dont want it to like overtaking a truck on an A road.

    I have tried the following;

    Changed the boost control valve
    Changed the lamda probe
    Changed the MAF meter
    Had the MAF meter wiring block re-wired.
    Tried sweet-talking the car

    None of which have solved it. I have already spent lots on diagnostics and havent even come close. Any ideas would be very much appreciated.

    I am in the UK

    #1
  2. Ads

    Ads

    [Nov 21, 2014]

  3. 20vTurboS2
    Offline

    20vTurboS2 New Member

    Joined:
    Apr 14, 2004
    Messages:
    1
    Likes Received:
    0
    [Apr 15, 2004]
    I have the same problem on my '94 S2 (ABY engine code). However, it's only surfaced twice in 3 years, each time it was in the winter when the whether was pretty cold. Let me know if you manage to solve your problem.

    Mick
    #2

Share This Page