1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RSN-E problems, dirty lens ?

Discussion in 'Satellite Navigation' started by churny, Jun 19, 2013.

  1. churny
    Offline

    churny New Member

    Joined:
    Apr 24, 2010
    Messages:
    15
    Likes Received:
    1
    Hi my unit has started to sometimes take an age to come on displaying "sat nav Initialising" before eventually working. If you try reinserting the disc it gives a disc unreadable warning.
    The disc I am using is genuine audi so I think the problem could be a dirty lens or even the heat as it is worse on hot days.

    I am happy to remove the unit but can someone tell me how easy the lens is to clean with regards access etc.and how to do it.
    I thought my first option would be to clean the unit with compressed air and use alcohol swab on the lens.
    #1
  2. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,228
    Likes Received:
    1,220
    Search the forum fella, I have detailed before how too clean the laser head.
    #2
  3. churny
    Offline

    churny New Member

    Joined:
    Apr 24, 2010
    Messages:
    15
    Likes Received:
    1
    I had been searching but change of key words and I found it - THANKS
    #3
    NHN likes this.
  4. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,228
    Likes Received:
    1,220
    Good man, nice to see people searching with varied words, its straight forward enough & don't be heavy handed, patients & take time, clean it few times not just 1 cotton bud & don't use the same end twice :)
    #4
  5. churny
    Offline

    churny New Member

    Joined:
    Apr 24, 2010
    Messages:
    15
    Likes Received:
    1
    well opened up unit ok and cleaned lens several times and to be honest first couple of times the cotton bud was dirty however still no joy.
    the unit is now showing "disc improperly inserted" I watched the unit with the top off and the disc does a short spin and then stops before the message.
    Also I forgot to take the disc out prior to removing the top of the unit, but the unit was switched of and the keys were out of the ignition. However when I removed the top the disc was still spinning, is this normal or part of my problem.
    guess I need to have the unit looked at by the pros
    #5
  6. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,228
    Likes Received:
    1,220
    Looks like a new laser or drive, often when people have these issues they look to swap the whole drive out or even upgrade the unit to the newer type, PM me for options as I do these repairs/upgrades.
    #6
  7. churny
    Offline

    churny New Member

    Joined:
    Apr 24, 2010
    Messages:
    15
    Likes Received:
    1
    well things seem much better, the unit is now working 100% so I guess dirt was the problem. Thanks for your help NHN
    #7

Share This Page