1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rs6 non-start

Discussion in 'RS6 Forum' started by murran, Oct 18, 2012.

  1. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    [Oct 18, 2012]
    got an old twin turbo rs6 avant in at work "bcy" engine. cars been stood a few weeks, was running fine before hand. it had a flat battery but wouldnt start on jumping it.
    engine cranks but wont fire.
    four fault codes.
    three fault codes to do with the throttle body, p1545, p1558 and p1579.
    and one ecu faulty code p1604.

    no signs of water ingress anywhere inside or in the engine ecu box.
    weirdly the cooling fans are also running full chat with the ignition on. pulling the 5amp fuse for the fan ecus under the drivers kick panel stops them running tho.
    on cranking theres no live to the coils and the ecu isnt giving out the switched ground to click in the fuel pump relay. but activating it with the power probe manually on cranking doesnt make it start either.
    ecu main relay is working and ive checked all lives/earths to the ecu.

    any ideas guys?
    #1
  2. Ads

    Ads

    [Sep 23, 2014]

  3. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    [Oct 18, 2012]
    i say old rs6, but its an 04 plate btw.
    #2
  4. AlexGSi2000
    Offline

    AlexGSi2000 Well-Known Member VCDS Map User

    Joined:
    Feb 14, 2012
    Messages:
    1,198
    Likes Received:
    118
    [Oct 20, 2012]
    Have you tried pulling the battery and leaving for 30 mins?

    Reason being my friend had a similar issue with his R32 when he swapped over his battery, he had a whole range of dash lights on too.
    #3
  5. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    [Oct 20, 2012]
    it was removed overnight for charging the day it came in.

    no updates as ive not had chance to look at it again since thursday.
    #4
  6. Gavin0478
    Offline

    Gavin0478 Active Member

    Joined:
    May 16, 2010
    Messages:
    455
    Likes Received:
    28
    [Oct 21, 2012]
    Was it brought in for this reason or was there another fault?
    #5
  7. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    [Oct 21, 2012]
    it was brought in with this fault. battery was flat when the customer tried starting it after it had been parked up for six or so weeks. customer tried jumping it to no avail. was recovered in.
    #6
  8. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,606
    Likes Received:
    278
    [Oct 21, 2012]
    As stated in other thread ECU fried
    #7
  9. AlexGSi2000
    Offline

    AlexGSi2000 Well-Known Member VCDS Map User

    Joined:
    Feb 14, 2012
    Messages:
    1,198
    Likes Received:
    118
    [Oct 22, 2012]
    Thats not good! - at least the customer is to blame though...

    Would have thought the ECU would have some kind of fused protection? - obviously not...
    #8
  10. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    [Oct 22, 2012]
    thats just it tho the car/ecu has fuses to protect it from such things. and ive replaced fuses on other audis that have blown from incorrect jumping procedure. non of these have blown.

    been busy today and still not had another chance to look at it again.
    on the plus side i diagnosed a dhrc fault on a 59 plate a5 and fitted and adapted a new suspension height sensor today amongst other jobs.
    #9
  11. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    [Oct 23, 2012]
    been checking out the throttle body faults, being a cause of it not starting.
    as with the throttle unplugged when you clear the codes you get back different codes to the above; "potentiometer 1 + 2 open circ." and "basic setting not performed" (which is one of the ones in my opening post). but the ecu internal fault p1604 isnt there.

    car still doesnt start with the throttle body unplugged, but if you cycle the ignition on and off once youve unplugged the throttle body.... the 5v to power the throttlebody is back. which goes with the throttle body plugged in and the p1604 is back..........

    with it being fly by wire will they normally start with the body unplugged??
    #10
  12. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    [Oct 24, 2012]
    its the throttle body.
    i found an old dusty second hand one off a v6 something upstairs at work.
    plugged it on the loom and earthed the body to the engine. put the ignition on and to my suprise it did its adaption and all the faults cleared! and then it started up and idled. rechecked and no faults.
    turned it back off and plugged the old one back in. it did start up but ran very rough on rechecking the codes there was 1 throttlebody fault back along with the p1604. but why it would now start up i dont know? its bloody wierd.

    anyway ive dropped the front panel forward and took the throttle off. theres an expencive new one coming from tps tomorrow.
    #11
  13. Ste_Nova
    Offline

    Ste_Nova Active Member

    Joined:
    Apr 20, 2012
    Messages:
    1,225
    Likes Received:
    43
    [Oct 24, 2012]
    #12
  14. Greeny233
    Offline

    Greeny233 Active Member

    Joined:
    Mar 17, 2011
    Messages:
    724
    Likes Received:
    127
    [Oct 24, 2012]
    Ha ha, that's mint. I know that tunnel, it's on the A55 in North Wales. It's where Richard Hammond tested the DB9 cabriolet on Top Gear and where I regularly thrash my VTR SP1. Great acoustics :eek:)
    #13
  15. Brodster
    Offline

    Brodster Shark Performance In Scotland Regional Rep Site Sponsor VCDS Map User

    Joined:
    Mar 17, 2011
    Messages:
    3,445
    Likes Received:
    806
    [Nov 2, 2012]
    Thats class that is. Reminds me of an old video of a massively tuned RS2. German guy was going on holiday with his family and 2 dogs in the boot. The car was fully loaded and as they overtook a Porsche 911 on the autobahn after toying with it his kids started waving at the Porsche driver much to his embarassment.
    #14

Share This Page