1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rough Idle

Discussion in 'A4/S4 forum(B5 Chassis)' started by ad3crk, Oct 7, 2006.

  1. ad3crk
    Offline

    ad3crk Member

    Joined:
    Aug 23, 2006
    Messages:
    59
    Likes Received:
    0
    [Oct 7, 2006]
    When my 2.8 gets warmed up after it gets over its cold start mode...the idle goes to pot..big flutuations...and when i drive, coming to a complete stop at a stop light or stop sighn vice versa...it pratically falls on its face but doesent die...i didnt do anything to the engine that would cause runnability probs and i searched the forum and cant find anything....help would be greatly appreciated
    #1
  2. Ads

    Ads

    [Oct 30, 2014]

  3. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    32
    [Oct 7, 2006]
    My 2.8Q started to do this a while back. Turned out the water pump was seizing up. Luckily it developed a leak so had to be swapped out before it completely seized and stripped the cambelt and most of my 30 valves. Audi had changed the cambelt at 75k miles but had failed to change the water pump at the same time saving me a valuable £35 on the £800 they charged for the cambelt change, w@nkers. Had to have the whole lot done again 10k miles later as changing the water pump involves the same amount of work as the cambelt. Luckily I'd found a VAG specialist by then who did the whole lot (water pump, cambelt & tensioner) for half the dealer price. They showed me the old pump and you could hardly turn the thing by hand so no wonder it was causing the engine to stall at idle.
    I'm not saying this is the problem with your 2.8 as it could easily be something else, but worth considering as the consequences don't bear thinking about. If the cambelt has been done you need to check the water pump was done at the same time. If it's due for a cambelt change then get it done ASAP along with the pump.
    #2
  4. dsmclark40v
    Offline

    dsmclark40v Member

    Joined:
    Sep 24, 2006
    Messages:
    725
    Likes Received:
    6
    [Oct 7, 2006]
    my 2.8 is doing the same thing. but it recently had the cam belt and water pump changed less than 10,000 miles ago so i am hoping it isn't the water pump. I increased the idle speed with vag com and thats stopped it stalling but it still doesn't feel right. I found this website about cleaning the ICV http://www.kris-hansen.com/Audi/icv.ht Has anyone done this
    #3
  5. dsmclark40v
    Offline

    dsmclark40v Member

    Joined:
    Sep 24, 2006
    Messages:
    725
    Likes Received:
    6
    [Oct 7, 2006]
    #4
  6. Chilli
    Offline

    Chilli New Member

    Joined:
    Jul 19, 2006
    Messages:
    14
    Likes Received:
    0
    [Oct 8, 2006]
    I will do this at the weekend - cheers for the link!
    #5

Share This Page