1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Roof problem on a B6 cabriolet

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by robbie21mcn, May 20, 2012.

  1. robbie21mcn
    Offline

    robbie21mcn New Member

    Joined:
    May 20, 2012
    Messages:
    5
    Likes Received:
    0
    Hi guys my car has developed a problem with the roof. it will go down no problem at all but when coming up to close stops at the very end and does not lock into place. if i use the manual tool it still displays the roof icon on my display as a solid light. my car always had the roof icon flash ten times on start up but worked perfectly. it does exactly the same as this youtube video i spotted. any advice would be really grateful thanks rob.

    How to fix my roof on Audi A4 convertible - YouTube
    #1
  2. bez101
    Offline

    bez101 Yorkshire & Humber Rep.

    Joined:
    Jul 8, 2008
    Messages:
    8,723
    Likes Received:
    491
    1st off is a manual reset
    you will find how to in the hand book
    2nd get it scanned it could be a micro switch or a sensor
    and theres quite a few
    #2
  3. robbie21mcn
    Offline

    robbie21mcn New Member

    Joined:
    May 20, 2012
    Messages:
    5
    Likes Received:
    0
    Where is the sensor located that tells the module that the roof is in position to lock. This would seem to be at the root of all my problems since when the roof is down all is well but when it gets into position on the pillars there is no signal to the front motor to pull the latches into place in order to finalize the close procedure. I took the motor out and it goes back and forward so cannot be this. :-(
    #3
  4. bez101
    Offline

    bez101 Yorkshire & Humber Rep.

    Joined:
    Jul 8, 2008
    Messages:
    8,723
    Likes Received:
    491
    its in the lock
    thats why i said do the manual reset as in handbook theres a good chance it will clear the error
    or scam it you will be wasteing cash and time just swapping parts
    iv done quite a few and its diffrent every time
    #4
  5. robbie21mcn
    Offline

    robbie21mcn New Member

    Joined:
    May 20, 2012
    Messages:
    5
    Likes Received:
    0
    when you say it is in the lock do you mean inside the soft top or inside the pillar at the top of the windscreen? i locked the roof into place using the tool but the car is still under the impression the roof is not secure even though mechanically it is. to me it is as if just before you lock the roof into position you had pressed the switch back to stop and then tried to drive. i get a warning saying soft top not secure. no errors or problems with the soft top down as the lock at the rear is working fine. is there any photos? i did take out the motor at the top of the soft top and it only has two micro switches near the motor to tell it to stop in either direction. i tested the motor and it was going backwards and forwards with a 9v battery.
    #5
  6. bez101
    Offline

    bez101 Yorkshire & Humber Rep.

    Joined:
    Jul 8, 2008
    Messages:
    8,723
    Likes Received:
    491
    like i said DO full manual reset look in the handbook not just lock it at the front doing this sorts it 90% of the time
    theres loads of sensors it can be that why i say get it scanned and it will point to the fault
    last time i had 1 that wouldnt lock on close it was a sensor on the drivers side rear in the hood
    #6
  7. robbie21mcn
    Offline

    robbie21mcn New Member

    Joined:
    May 20, 2012
    Messages:
    5
    Likes Received:
    0
    i didn't do a full reset as i thought because it had done most of the operation itself up until the last procedure of locking. i will give the full reset a bash tomorrow and get back to you. thanks for the help in the meantime.
    #7
  8. bez101
    Offline

    bez101 Yorkshire & Humber Rep.

    Joined:
    Jul 8, 2008
    Messages:
    8,723
    Likes Received:
    491
    no probs but by it doing most and you just locking thats wont work
    #8
  9. robbie21mcn
    Offline

    robbie21mcn New Member

    Joined:
    May 20, 2012
    Messages:
    5
    Likes Received:
    0
    still not functioning guys. how does the roof know it is to lock when it gets to the very last stage? is there a sensor that tells it is in poisition? even when manually locked down it flashes above 40mph telling me the roof is not secure so to me it appears as if the car thinks the roof is still unlocked at the front of the windscreen. :-(
    #9
  10. bez101
    Offline

    bez101 Yorkshire & Humber Rep.

    Joined:
    Jul 8, 2008
    Messages:
    8,723
    Likes Received:
    491
    if the manual reset didnt work
    you really need it scanning see what code you get and take it from there
    guessing is gona cost you loads
    #10
  11. rjm180
    Offline

    rjm180 Member

    Joined:
    Mar 28, 2009
    Messages:
    475
    Likes Received:
    12
    As Bez has said, have you tried manually opening fully, locking cover with roof key, closing, locking with roof key, re-opening etc, a full cycle if i remember from reading other problems people have had. I think there are quite a few similar past threads desribing a full reset. This does usually clear problems. If you have tried that fully, then a scan is the next course of action to be able to diagnose further. Good luck.
    Last edited: May 24, 2012
    #11
  12. bowen
    Offline

    bowen Member

    Joined:
    Mar 28, 2011
    Messages:
    457
    Likes Received:
    14
    manual reset; open and close full cycle on a flat level surface.
    #12

Share This Page