1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rns-d system amp upgrade problems..... strange distortion!

Discussion in 'In-Car Entertainment' started by shufti, Nov 14, 2007.

  1. shufti
    Offline

    shufti Member

    Joined:
    Dec 23, 2005
    Messages:
    211
    Likes Received:
    0
    [Nov 14, 2007]
    hi guys

    I finally settled on my system after many trials and errors of systems but only to hit a brick wall that's left me and a few others scratching our heads!

    i have an rns-d in dash sat nav.... i bought the pre made loom for quick install to my 2001 a6 avant and the extra front and rear rca pre out lead for my upgrades.

    this is how my system is installed........ from the back of the rns-d a single stereo rca goes to a clif audio design in dash parmetric eq and 8volt line driver. the front and rear rca outs from eq goes to a mtx 4 channel amp running 4 jl audio 6.5" components in all doors. the sub out from the eq going to mtx mono amp running 12" kicker l5 sub in box. I'd like to think I've done a good install using top end power, ground, rca and speaker cables and dynamat in the boot and the skinz acoustic system in all doors, there's also a 1 farad power cap in line.

    right the problem........ when I turn up the system it gets to a peak then if i demand more bass from the eq the whole system incredibly distorts while the volume seems to get louder and quieter like some pulse! it's really hard to explain the speaker cones are literally pushing and pulling! the guys at my local stereo shop were scratching their heads knowing full well that the system should kick and with some sort of quality and quite frankly it sounds ****. it probably distorts at about 20% of potential volume. it's like the system is drawing too much power as the interior lights also dim at this point but there is a power cap on there and all the wiring checks out as does the battery.

    the guys in the shop reckon it's the head unit at fault as the demand from the bass makes all speakers go crazy not just the sub. I know the parametric eq and mtx amps are ok as i also had the same problem before when i had a different amp and sub direct from the rns-d rear pre out running as my temporary set up....

    i've swapped over the front and rear pre outs from the sat nav and still the same problem!

    does anyone have any suggestions?
    #1
  2. Ads

    Ads

    [Oct 1, 2014]

  3. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    31
    [Nov 14, 2007]
    Get rid of the powercap for starters.
    #2
  4. shufti
    Offline

    shufti Member

    Joined:
    Dec 23, 2005
    Messages:
    211
    Likes Received:
    0
    [Nov 17, 2007]
    nothing wrong with the cap whatsoever but thanks for the reply

    i sorted the problem.... if it helps anyone else that gets a similar pulsing distortion at certain draw levels an rca ground loop isolator got rid of the problem for me.
    #3

Share This Page