1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rewiring b6 avant non bose rear speakers and sub into after market headunit...

Discussion in 'In-Car Entertainment' started by millwrx, Nov 14, 2010.

  1. millwrx
    Offline

    millwrx Member

    Joined:
    Sep 22, 2006
    Messages:
    223
    Likes Received:
    0
    [Nov 14, 2010]
    just in the process of rewiring my b6 avant non bose for my radio,dvd,tv,gps headunit,put it in today and found two faults,one being the aerial adaptor that came with it doesnt seem to do anything,its got the 12v blue wire feed,and powers up but doesnt seem to work,i know the b6 has a aerial box in the back which switches to get the best signal,may do away with all of that and just buy one of the ones that stick on the inside of the windscreen and just bypass all the audi stuff,just seems to be easyer??unless anyone knows a easyer way to get round it????also when the hu is plugged in both the front speakers work fine as these are powered off the headunit,the sub works and so does the lefthand rear speaker/tweeter,but the right rear just has a faint hissing noise coming from it??if i could find why the righthand speaker isnt working then i may leave it alone,the other way would be for me to run two wires from the hu and run the rear speakers of the 45wx4 hu as i have now found a photo of the rear amp wiring plug,if i do that can someone tell me can i just bridge the two wires +/- from the sub on to the new hu wires,- onto the left rear and the + onto the right rear???does the sub have a low pass filter??any help will help.
    cheers ​
    #1
  2. Ads

    Ads

    [Oct 23, 2014]

  3. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    31
    [Nov 15, 2010]
    No you can't bridge the feed from the HU you will destroy it. Only separate amps can be bridged. Unless you are installing a new amp for the sub then you still need to use the Audi rear/sub amp but just for the sub. Sounds like the amp is working if you are getting a hiss, but the feed from the new HU is not connected. Ensure the RCA's are secure and just check you haven't connected the sub out to the righthand feed on the adapter by mistake.
    #2
  4. millwrx
    Offline

    millwrx Member

    Joined:
    Sep 22, 2006
    Messages:
    223
    Likes Received:
    0
    [Nov 15, 2010]
    ok cheers for that,its not connected via rca's,the loom that came with the radio plugs into the audi loom,so everything is still as it was out of the factory,the headunit powers the front and centre dash speaker,which leaves the back end to be powered by the amp,its just that the righthand speaker does not produce any sound only a faint hiss,the left one and the sub work fine,if i do decide to cut the four wires off the amp blue conector block and put in my own wires for the hu to run the rear speakers do i just leave the sub wires alone???guessing these still pick up the signal from the headunit from the white and green rear pre-out wires on the blue connector block,guessing the rear speakers will be louder too as the headunit is 4x45w and the audi amp is something like 20w???????
    #3
  5. millwrx
    Offline

    millwrx Member

    Joined:
    Sep 22, 2006
    Messages:
    223
    Likes Received:
    0
    [Nov 15, 2010]
    any ideas on the aerial too???
    cheers
    #4
  6. millwrx
    Offline

    millwrx Member

    Joined:
    Sep 22, 2006
    Messages:
    223
    Likes Received:
    0
    [Nov 17, 2010]
    brought one of those celsus amplified screen mount antennas,far easyer to wire in plus it means i dont have to mess about with the audi aeriel setup which tobe fair wasnt that good anyway,have also brought some high end speaker cable which i'm going to run to the rear and then cut the four wires off the blue amp connector block and run the rear door speakers off the headunit which will sound better and more in tune with the front,as the standared wiring setup picks its feed for the sub/rear speakers from the iso block which feeds the front speakers the sub will remain powered from the audi amp,last thing will then be to transfer my copliot software to a sd card and install that on to the set for the satnav.
    #5

Share This Page