1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Revving on Idle

Discussion in 'A3/S3/Sportback (8P Chassis)' started by LucasS3, Feb 1, 2012.

  1. LucasS3
    Offline

    LucasS3 Member

    Joined:
    Mar 16, 2011
    Messages:
    112
    Likes Received:
    8
    Hi all,

    Don't often comment on here but use this site a hell of a lot for help and ideas, but this time I really need your help. My Car 58 S3, as of last night decided to start revving whilst on idle, I found a clip on youtube which is doing exactly what mine is, can any one shed some light onto this? Had a service about two months ago, at 38K.

    Erratic idle 8P Audi S3 + Fix - YouTube

    Thanks you for any help, just want to see if it's something I can do or is it going to be a trip to audi for them to pull my pants down! BTW I know how to drive a car I have no idea of fixing one so please go gentle!

    Cheers

    Lucas
    #1
  2. paddy
    Offline

    paddy Audi=No fault code, no idea

    Joined:
    Feb 6, 2008
    Messages:
    5,133
    Likes Received:
    122
    Probably not what you want to hear but first step is always VCDS to check for faults logged before you then look for an air leak somewhere on the induction side.?
    #2
  3. LucasS3
    Offline

    LucasS3 Member

    Joined:
    Mar 16, 2011
    Messages:
    112
    Likes Received:
    8
    Has to go to Audi then for that?
    #3
  4. Paullie
    Offline

    Paullie Banana Menace!

    Joined:
    Jan 19, 2011
    Messages:
    2,088
    Likes Received:
    267
    Hi Lucas, it doesn't have to go to Audi for a diagnostics check. Lots of members all over the UK have VCDS, have a look at the VCDS Users Map and see if there is anyone local to you who can plug your car in to see what's wrong, for the cost of a few tins. Depending on what's up - as Paddy says, it could just be a split vacuum hose - you may not even have to resort to taking it to Audi at all. :wub: xx

    http://www.audi-sport.net/vb/vcds-formerly-vag-com-forum/84603-%2A%2A%2Avcds-users-map%2A%2A%2A.html
    #4
  5. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    bet i know what this is! had this on one at work.
    under the airbox engine cover. bolted to the front of the rocker cover with 4x 20 torx is an engine breather valve. there is two pipes clipped on to it. one from the engine breather under the inlet manifold. and one directly from the inlet manifold.
    the one i looked at last week.... the valve had gone faulty allowing the crankcase to be subjected to the full vacuum in the inlet manifold.

    it had fault codes; misfire detected on all 4 cylinders, mixture too lean and induction system air leak.

    i replaced the valve unit (£29 from tps) took 10 mins. cleared codes. idled perfect again.
    #5
  6. marknjayne
    Offline

    marknjayne Member

    Joined:
    Sep 10, 2011
    Messages:
    426
    Likes Received:
    15
    if its idle hunting its more than likely the air flow meter but it looks from the vid its trying to stabilise so maybe a vacume issue
    #6
  7. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    simple test.... without having to strip anything, with it idling can you remove the oil cap? normally you can quite easily.
    but..... i suspect in your case... you can twist it to undo it but at that point does it feel held down by vacuum?
    #7
  8. LucasS3
    Offline

    LucasS3 Member

    Joined:
    Mar 16, 2011
    Messages:
    112
    Likes Received:
    8
    Thanks all I will try your tip Murran, it is strange as its only happening one in three journeys, on the way to work this morning it was fine yet last night coming home from the gym it was revving, which is horrible when you drop to second to slow down and because the revs are holding it at 2000rpm its driving like an automatic!!
    My friend works at Seat so I took it to him last night to plug it in and he said no errors, but typical it wasn't revving to show him.
    #8
  9. LucasS3
    Offline

    LucasS3 Member

    Joined:
    Mar 16, 2011
    Messages:
    112
    Likes Received:
    8
    Just heard back from my mate at Seat and he said that their was an error code and it said it was the Throttle Body, I really know nothing about cars, what is it and how much! lol
    #9
  10. warren_S5
    Offline

    warren_S5 Moderator Staff Member Moderator

    Joined:
    Oct 31, 2007
    Messages:
    7,176
    Likes Received:
    2,358
    What about the throttle body???.

    If it needs realignment you can do this on VCDS. I drive through Swindon once a week on my way to Cheltenham but not due to go again till end of next week.

    Can he tell you what error code?
    #10
  11. LucasS3
    Offline

    LucasS3 Member

    Joined:
    Mar 16, 2011
    Messages:
    112
    Likes Received:
    8
    Where abouts you from then Warren, do you have VCDS?
    #11
  12. warren_S5
    Offline

    warren_S5 Moderator Staff Member Moderator

    Joined:
    Oct 31, 2007
    Messages:
    7,176
    Likes Received:
    2,358
    You have PM
    #12
  13. LucasS3
    Offline

    LucasS3 Member

    Joined:
    Mar 16, 2011
    Messages:
    112
    Likes Received:
    8
    Cheers Warren. Will keep you all updated on what it is and what is done to fix the problem.
    #13
  14. LucasS3
    Offline

    LucasS3 Member

    Joined:
    Mar 16, 2011
    Messages:
    112
    Likes Received:
    8
    Murran you were absolutly right, tried to pull the Oil cap off could hardly move it then a big intake of air as I freed it. Right so is this something I can do easily enough what you explained? And where would I get the part from?
    #14
  15. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    you can get the part from the dealer. or tps directly. Trade Parts Specialists. i dont know the part number of the bit you need tho. youd have to explain what it is and where it fits. im sure theyd know from a brief description......
    reguarding doing the job. the only difficult bit is pulling the top engine cover off. theres an intake pipe on the top left (theres two spring clips holding it on) and you'll need to unplug the airmass sensor (the plug near the pipe youve unclipped)
    the engine cover is mounted on rubbers doofers that pull off/push on. get hold of the cover at one corner and pull it up, then do the other corner. the rubbers can get a good grip tho. so dont be scared of giving it a good yank! (a tiny smear of oil in the doofers when you put it back on, likewise the seal on the inlet pipe.)
    you can now see what your changing. the valve unit. its black plastic with a round disc/valve with two pipes clipped to the unit its on the side of the rocker cover facing you almost on top of the inlet manifold.
    to unclip the pipes you pinch the clippy bit at each side to release the pipes. and like i said theres 4x t20 torx screws holding it to the rocker cover.
    fit the new one, make sure the rubber gasket to the rocker cover is still inplace and try not to drop the screws! the one on the right is slightly hidden/awquard.
    #15
  16. warren_S5
    Offline

    warren_S5 Moderator Staff Member Moderator

    Joined:
    Oct 31, 2007
    Messages:
    7,176
    Likes Received:
    2,358
    Can the PCV cause vacuum issues?
    #16
  17. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    the pcv valve is the valve the unit.
    #17
  18. LucasS3
    Offline

    LucasS3 Member

    Joined:
    Mar 16, 2011
    Messages:
    112
    Likes Received:
    8
    You are all being a great help I will give this ago, Warren hold off for now I will see if this works what Murran is describing, for the sake of £50 its worth ago.
    #18
  19. Paullie
    Offline

    Paullie Banana Menace!

    Joined:
    Jan 19, 2011
    Messages:
    2,088
    Likes Received:
    267
    Great to see the guys all helping each other out as usual. This site is full of love!! :wub: xx
    #19
  20. LucasS3
    Offline

    LucasS3 Member

    Joined:
    Mar 16, 2011
    Messages:
    112
    Likes Received:
    8
    Update, Murran, you were right I got the Valve & Gasket from Audi then took it to a friend who fitted the part in 10 mins like you said, the hardest thing was getting the bloody engine cover off, nightmare, be easier next time as greased up now!! But fixed the problem right away, no more revving on idle, case closed.... A big thanks
    #20
  21. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    thats brilliant! did you delete the fault codes after?
    can you now remove the oil cap easily with it ticking over? does it upset the idle when you remove it?
    #21
  22. LucasS3
    Offline

    LucasS3 Member

    Joined:
    Mar 16, 2011
    Messages:
    112
    Likes Received:
    8
    No fault codes funnily enough! The funny thing is it really is a 10 min job, but my god how hard is it to get the engine cover off!!! Drove it round the block after he fitted the new valve and was great, checked the oil cap after there was a little suction but the mechanic said that was normal, but it was 100% easier to undo than before the new valve. I certainly owe you a beer, you saved me a lot of money.
    #22
    Hoesty likes this.
  23. warren_S5
    Offline

    warren_S5 Moderator Staff Member Moderator

    Joined:
    Oct 31, 2007
    Messages:
    7,176
    Likes Received:
    2,358
    Spot on mate, glad its been resolved. Good skills Murran!
    #23
  24. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    :)
    strange that it had no codes.
    the one i did at work had misfire detected cyl 1,2,3+4. a weak misture code and a unmetered/air leak code.

    wierd!
    Last edited: Feb 7, 2012
    #24
  25. S3RYE
    Offline

    S3RYE Interior Next!!

    Joined:
    Apr 20, 2009
    Messages:
    3,460
    Likes Received:
    67
    Hi Murran, Suffering the same issue with mine! can i do this oil cap check with the engine cold??

    thanks in advance!!
    #25
  26. S3RYE
    Offline

    S3RYE Interior Next!!

    Joined:
    Apr 20, 2009
    Messages:
    3,460
    Likes Received:
    67
    right just been out to try it cause im impatient and you are spot on! was a suction going on then as i pulled it out it let out a burst of air!! the idle was affected by this too. Going to call TPS now. Anyone got a part number for this valve!? i also need a new cam follower so can kill two birds with one stone!!
    #26
  27. _G_
    Offline

    _G_ Member

    Joined:
    Jul 24, 2011
    Messages:
    872
    Likes Received:
    34
    whats the part no. and part name? I have this prob too. It started earlier this week. Freaked me out just sat in traffic at idle and it shot up to 2k by itself... had to check my foot wasnt on the gas and i wasnt!
    #27
  28. J3NKO
    Offline

    J3NKO Member

    Joined:
    Dec 3, 2009
    Messages:
    75
    Likes Received:
    4
    I'm struggling, spoken with local dealership and Euro Car parts but neither know what I'm on about when giving them the descriptions and functions described above... I have a '55 2.0T FSI so can anyone give me a part number please?
    #28
  29. pinterovski
    Offline

    pinterovski Member

    Joined:
    Oct 14, 2010
    Messages:
    667
    Likes Received:
    88
    PCV!!!
    #29
  30. J3NKO
    Offline

    J3NKO Member

    Joined:
    Dec 3, 2009
    Messages:
    75
    Likes Received:
    4
    Nope, didn't know it by that either!!!
    #30
  31. J3NKO
    Offline

    J3NKO Member

    Joined:
    Dec 3, 2009
    Messages:
    75
    Likes Received:
    4
    ASN

    Ta
    J3NKO
    #31
  32. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    read posts and click on links and you'll find what you need.
    the link i put up earlier on.
    Problems :( Irratic idle issues
    ^^^ 2/3rds of the way down is "s3rye's" fitting guide with pics and part numbers.
    #32
  33. volkskid
    Offline

    volkskid New Member

    Joined:
    Jan 9, 2010
    Messages:
    25
    Likes Received:
    0
    I had erratic idle during cold starts at 1k rpm as revs drop to 800 rpm, no idle issue on warm starts. My 2009 S3 Sportsback was running the older version breather control valve, changed it to the newer version and resolved the idling issue. Best of all, the car felt much stronger like it found some lost bhp and torque and my exhaust sounds louder too. Can anyone explain how a faulty PCV could restrict power?
    #33
  34. wuta3
    Offline

    wuta3 Well-Known Member

    Joined:
    Jul 1, 2012
    Messages:
    1,099
    Likes Received:
    339
    Bloody PCV valves.
    #34
  35. J3NKO
    Offline

    J3NKO Member

    Joined:
    Dec 3, 2009
    Messages:
    75
    Likes Received:
    4
    All sorted now thanks Murran, fitted it on Saturday and I still have a slight issue but its a lot better as a result so cheers for the advice above.

    J3NKO
    #35
  36. Bloodhound
    Offline

    Bloodhound New Member

    Joined:
    May 26, 2012
    Messages:
    1
    Likes Received:
    0
    Murran your advise on this matter has been great, exact same thing happen to me bought the part £50, audi wanted £120 to fit it on top followed your sets an problem sorted running sweet!! many thanks!!
    #36
  37. Mujnu
    Online

    Mujnu New Member

    Joined:
    Dec 31, 2013
    Messages:
    28
    Likes Received:
    0
    Sorry to dig up an old thread, but I've been scouring this forum and a lot of others but no one seems to have the same probem as me lol :/

    My car is a 55 (06) plate A3 1.9tdi, BKC engine code with 120k on the clock.

    I've realised when my car is idle my revs will rise from approx 850-900 rpm and sit on 1000rmp (just a little above). This can be from a cold start, when i start the car first thing in morning the revs will rise and as the engine warms up it'll auto-rev to 1000rpm every time i sit at idle. When the revs do rise if i press the accelerator it'll drop back to 850rmp only to rise a few seconds later.
    Ive also realised every time the car revs the fans kick in for about 30-45 seconds and then stop but the revs will stay at 1000rpm. I have checked battery voltage and its not a bad battery causing it.

    Theres no codes apart from glow plugs which i don't think should effect the rpm, so not sure what it is, any help would be much appreciated lads. Thanks
    #37
  38. Hoesty
    Online

    Hoesty Member

    Joined:
    Dec 1, 2013
    Messages:
    146
    Likes Received:
    24
    Got same issue just today. What was your solution and outcome? I'll be taking mine to dealership tomorrow.
    #38
  39. Mujnu
    Online

    Mujnu New Member

    Joined:
    Dec 31, 2013
    Messages:
    28
    Likes Received:
    0
    Tbh mate I've not come round to fixing it just yet but I did have a diagnostic done and there was some kind of electrical fault logged I totally forgot to write down the codes so have nothing to research on atm.
    But I know it was something to do with the electronic control module. Apparently my AC is always running even though I'm not using it regardless of if I put it into econ mode or not. And because the ac is coming on the car revs itself as it would have done if I was actually switching my ac on if that makes any sense lol

    But when I do get it onto a vagcom again I'll defo update it here. Let me know your outcome please. Would be of great help.
    #39
  40. Hoesty
    Online

    Hoesty Member

    Joined:
    Dec 1, 2013
    Messages:
    146
    Likes Received:
    24
    Ok man ill update soon thanks for sharing and hope you get it fixed soon.

    Mine is a little different as it revs up to about 2k rpms and back to 1k rpm on idle. Ppl thought I'm having a go at Red lights lol

    Annoying
    #40

Share This Page