1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. baztard

    baztard New Member

    2
    0
    1
    Hi all just got a 03 a4 1.8t 190hp when changing gear there's a delay in the rev's coming back down any help or this normal cheers
     
  2. Jp-tqs

    Jp-tqs Member

    183
    8
    18
    Hi mate, got the same engine as yours. Cant really understand whats going on from your description!! More detail please!
     
  3. marktdisport

    marktdisport Active Member

    1,195
    15
    38
    Sounds like the clutch switch is faulty causing revs to hover and stick whilst changing gears, getting it scanned might help
     
  4. stu_m

    stu_m Well-Known Member VCDS Map User

    1,440
    38
    48
    As above

    clutch switch makes your revs drop

    If you have cruise you can easily check the clutch switch by seeing if your cruise works if not then thats your problem

    if no cruise you could always remove the plug from the switch bridge it with a bit of wire and if the revs drop when you drive then you need a switch

    £13 ish from the stealer's
     
  5. baztard

    baztard New Member

    2
    0
    1
    hi mate when you rev car in neutral rev's drop normal when you driving through the gears rev's tend to hover for slight time, How does your's respond.
     
  6. hades-

    hades- Yorkshire & Humber Rep. Regional Rep VCDS Map User

    9,470
    645
    113
    as the 2 above clutch switch
    cheap and easy to fit
     

Share This Page