1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

REVO SPS question?

Discussion in 'A3/S3 Forum (8L Chassis)' started by Samp20v, Jan 16, 2009.

  1. Samp20v
    Offline

    Samp20v New Member

    Joined:
    Nov 28, 2008
    Messages:
    11
    Likes Received:
    0
    Hi Guys,

    Right what im wondering is can an SPS3 (i think, the type which allows tweaking of boost and timing plus immobiliser), be used on both 8P and 8L cars?

    Using the unit on an 8P works fine, although cant acuire the current settings in the ECU, but appears to send new settings to the ECU,

    but on the 8L it provides a "ECU timeout" error, cant quite remember the wording but basically saying it hasnt seen the correct response from the ECU in time.

    So is there two different versions of the SPS3, one for 8L and one for 8P era cars with the later canbus comms?

    We asked a Revo programmer at the GTI show and he said it would work on both cars??

    If anyone can shed some light on this for me it would be greatly appreciated......

    Craig.
    #1
  2. Carl.S
    Offline

    Carl.S Member

    Joined:
    Jun 18, 2008
    Messages:
    194
    Likes Received:
    2
    the select plus will work with both cars;

    the earlier sps3 (the one with the two dials) will only work with the 8L ;)
    #2
  3. Samp20v
    Offline

    Samp20v New Member

    Joined:
    Nov 28, 2008
    Messages:
    11
    Likes Received:
    0
    Thanks for the reply Carl, i know you have already told me how to search for new ECU type with the select plus, i have tried that but it still wont work.

    The unit im using is a Revo select plus fine tune.(Part no. RSP01)

    The software looks for new ecu type, but always times out with no response????


    The original remap was done by Fontain in Iver, Bucks, it was just a standard stage 1 remap, is there any chance they could of loaded a map that wasnt suitable for making adjustments using the select plus?

    The car is an 8L 1.8T AUM.

    Any help is much appreciated :thumbsup:
    #3
  4. Carl.S
    Offline

    Carl.S Member

    Joined:
    Jun 18, 2008
    Messages:
    194
    Likes Received:
    2
    have you got an aftermarket stereo in the car?
    #4
  5. Samp20v
    Offline

    Samp20v New Member

    Joined:
    Nov 28, 2008
    Messages:
    11
    Likes Received:
    0
    Yep, is it the old problem of shorting the k-line out or something like that due to having an aftermarket stereo?

    I think ive seen something or Ross-Techs website about fixing the issue, what would you recommend?
    Does the Select plus have a built in safety feature to prevent damage to it in this instance?


    Thanks.
    #5
  6. Carl.S
    Offline

    Carl.S Member

    Joined:
    Jun 18, 2008
    Messages:
    194
    Likes Received:
    2
    chances are the k-line has been spliced into or potentially shorted so there is no way for the switch to communicate with the ECU. The switch will be fine but won't communicate properly untill a full k-line connection is restored!
    #6
  7. Samp20v
    Offline

    Samp20v New Member

    Joined:
    Nov 28, 2008
    Messages:
    11
    Likes Received:
    0
    Thanks for clearing that up Carl, i shall have a look on the stereo connector and disconnect the K-line pin if required, Ross-tech list the problem on their website and thats what they say to do.
    I cant imagine the K-line is broken as all other components work correctly and using Vag-com i can get comms with them all, its just the select plus which is strugling.
    But once i sort that problem it should all be cool,

    Thanks again mate much appreciated :thumbsup:
    #7
  8. Samp20v
    Offline

    Samp20v New Member

    Joined:
    Nov 28, 2008
    Messages:
    11
    Likes Received:
    0
    Right thought id just add a quick update to this, i have taken the stereo out to make sure the adapter for the aftermarket stereo hasnt been connected into the K-line, but it hasnt.

    So tried using the select plus again, still wontget comms using the laptop to retrieve settings from the ECU, but, if i use the unit as a standalone, after two or three attempts in a row the ecu takes the new settings, whether it be the immobiliser, stock settings or performance A,B,C.

    So im happy the select plus works, not being able to use the laptop isnt a big deal but does seem strange as to why i cant??????
    Any ideas??????
    Could it be a compatibility problem between the software version of the Revo select plus that i have and my particular ECU???
    #8
  9. Carl.S
    Offline

    Carl.S Member

    Joined:
    Jun 18, 2008
    Messages:
    194
    Likes Received:
    2
    some of the 8L's and the MK1 TT's had comunication lines that ran through the instrument cluster that could make comunications with the ECU a little flakey at times, could be the problem....
    #9
  10. Samp20v
    Offline

    Samp20v New Member

    Joined:
    Nov 28, 2008
    Messages:
    11
    Likes Received:
    0
    Thanks again Carl, is this just something im going to have to live with???

    As i say its not a major problem, but when i start fine tuning my settings, say increasing boost by 1 unit, its hard to know 100% whether it has actually uploaded the settings, but if i could verify it with the laptop it would be easier, although i do have vagcom so can log the results.

    Ive turned the boost and timing up a little and it goes MUCH better, esp at the top end, you can feel the benefit of more ignition! :happy:
    #10
  11. Carl.S
    Offline

    Carl.S Member

    Joined:
    Jun 18, 2008
    Messages:
    194
    Likes Received:
    2
    have you got vagcom?

    if so you should be able to communicate using your laptop by pulling the fuse for the instrument cluster.

    but you will get a DTC for the airbag/instrument cluster so you need vagcom to clear the light
    #11
  12. Samp20v
    Offline

    Samp20v New Member

    Joined:
    Nov 28, 2008
    Messages:
    11
    Likes Received:
    0
    Yep got vagcom, ill try pulling the fuse then.

    Again, many thanks Carl. :beerchug:
    #12
  13. Carl.S
    Offline

    Carl.S Member

    Joined:
    Jun 18, 2008
    Messages:
    194
    Likes Received:
    2
    not a problem! :)
    #13

Share This Page