1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rev counter/Speedo fault and trouble codes to boot!

Discussion in 'A3/S3 Forum (8L Chassis)' started by Dizz, Oct 25, 2012.

  1. Dizz
    Offline

    Dizz New Member

    Joined:
    Oct 21, 2012
    Messages:
    9
    Likes Received:
    0
    [Oct 25, 2012]
    Any advice would be great here, I have scoured the net and quite honestly could scare myself with some of the explanations of what could be wrong.

    Vehicle in question: A3 8L 1.9 TDI << owned for a week :)

    Firstly I bought a scanner, scanned the car and checked the readings. I then cleared them and have the following codes from a second scan of the car:

    17656/P1248/004680 - Start of Injection Timing Regulation: Control Deviation

    18027/P1619/005657 - Glow Plug Relay (J52): Open or Short to Ground

    01314 - Engine Control Module



    I have read that the above linked with an ESP light (which does come on) could be to do with the cam belt change that it had, in the service history that was 2 years ago?? something to do with basic coding for the fuel timing <<< Is this true? It does affect high speed, seems to pick up extremely slowly on the motorway. These are the only codes that are appearing on the scanner (not vcds).

    Next on the list is the cluster. The Rev counter works on start and then works down to zero (sometimes after 5 mins or can last an hour on the motorway) Speedo has moved once after I took the cluster out, the securing bracket on the motor had snapped so I glued it back together to see if it would work. It shot up on start and settled back to zero after 100 yards or so.
    I am at a loss now, i have replaced the VSS and the cruise control works so I presume a speed signal is sent to the ECU for that to function. My thought is that the motor is goosed at that is screwing up the rev counter o_0 Needless to say I think my only options are now send the cluster for repair or buy a used cluster and have my local audi dealer program it.

    Last on my weekly to do list is the thermostat I think, the temp gauge rises to 90 and drops in between 70 and 90 throughout any journey I make. Climate control still seems to be working correctly at the moment.

    I'm a total noob with Audi's and TDI's as you may tell haha so any advice is greatly appreciated.
    #1
  2. Ads

    Ads

    [Sep 22, 2014]

  3. Dizz
    Offline

    Dizz New Member

    Joined:
    Oct 21, 2012
    Messages:
    9
    Likes Received:
    0
    [Oct 28, 2012]
    T-stat changed yesterday and has resolved the wobble in temperature. No change in any codes after removing the crank sensor and giving it a clean.

    Cluster is gonna be sent off to be repaired in November :) hopefully cure the broken Rev/Speedo.

    Glow plug relay to be changed this week with the coolant sensor to try and cure the other codes, running out of ideas!
    #2
  4. Dizz
    Offline

    Dizz New Member

    Joined:
    Oct 21, 2012
    Messages:
    9
    Likes Received:
    0
    [Jan 30, 2013]
    Update for my solo posting thread:

    Head done this week :( ........ like a new car now :) apparently it was warped to f*$k.....time to spend some more quality time in the engine bay tidying it up.
    #3
  5. @udi A3
    Offline

    @udi A3 Site Sponsor Site Sponsor VCDS Map User

    Joined:
    May 25, 2012
    Messages:
    1,766
    Likes Received:
    175
    [Jan 30, 2013]
    Cluster could be swapped with a second hand one quite easily, I have done this with mine.
    #4
  6. Dizz
    Offline

    Dizz New Member

    Joined:
    Oct 21, 2012
    Messages:
    9
    Likes Received:
    0
    [Jan 31, 2013]
    How easy is easy?? I've read that you have to have them re-coded and the mileage will not be right?
    #5

Share This Page