1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Red Oil light...HELP

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Christos Petrakis, May 4, 2013.

  1. Christos Petrakis

    Christos Petrakis New Member

    Joined:
    May 4, 2013
    Messages:
    1
    Likes Received:
    0
    Alright guys, I have a 1.4 A3 (09) and to be honest. it was due a service aroun 6000 miles ago.
    Thing is, a red oil light came up saying to stop car and check oil (flashing). I did this, it was low so topped it up. 3 days later, same thing happened. I checked the levels which said it was full but put in the rest of the bottle anyway.
    Now a week and a half later, its happened again though again... the level is showing a full volume of oil. Seems to be when this happens, i switch off the engine for a few mins and the light gos away when i restart ignition.

    Any ideas?
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. Vex182

    Vex182 Guess what I drive...

    Joined:
    Apr 23, 2012
    Messages:
    1,034
    Likes Received:
    78
    Best to ask in the A3 8P forum, this is for the 8L up to 2003. Sounds like a oil pressure problem or possibly a sensor.
     
  4. A3_130

    A3_130 Member

    Joined:
    Oct 24, 2012
    Messages:
    85
    Likes Received:
    4
    Oil pressure sensor maybe?? I had one play up on a Golf I had where the light came on saying 'stop, check oil' on the display so I did and checked the level. There was plenty of oil so I replaced the oil pressure sensor to see if that was the problem and that solved it. If the level isn't low then don't put too much oil in - it's not a good idea to overfill with oil.
     
  5. Minstadave

    Minstadave Member

    Joined:
    Jul 5, 2010
    Messages:
    560
    Likes Received:
    19
    Check the dipstick to start with.
     
  6. audicruiser

    audicruiser Audi Heaven

    Joined:
    Feb 14, 2010
    Messages:
    1,865
    Likes Received:
    46
    I think he's done that!

    As said it sounds like a oil pressure sensor issue....
     
  7. Minstadave

    Minstadave Member

    Joined:
    Jul 5, 2010
    Messages:
    560
    Likes Received:
    19
    Missed that bit oops! Does very much sound like a sensor issue. But also be careful as you've probably overfilled with oil now too, I'd drain off until you're under the max on the dipstick them have it looked at.
     
    audicruiser likes this.

Share This Page