1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rear wiper on audi a4 avant

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by kashiskash, Feb 15, 2010.

  1. kashiskash

    kashiskash Member

    Joined:
    Jan 22, 2009
    Messages:
    34
    Likes Received:
    0
    The rear wiper on my 2003 A4 Avant keeps coming on on its own what the heck is going on?
     
  2. Advert Guest Advertisement


  3. quattrojames

    quattrojames Moderator
    Staff Member Moderator Audi A6 Audi Avant Owner Group

    Joined:
    Mar 28, 2008
    Messages:
    14,043
    Likes Received:
    562
    Sounds like a relay problem?
     
  4. paul20v

    paul20v Audi fanatic

    Joined:
    May 24, 2009
    Messages:
    1,113
    Likes Received:
    3
    Doesnt the rear wiper have the control unit built in (well at least the B5 one does anyway)
    then what happens is the washer system fills the motor up ( because the seal packs up) and in turns starts buggering the circuits up in the motor and giving funny results till eventually it stops working all together.
     
  5. kashiskash

    kashiskash Member

    Joined:
    Jan 22, 2009
    Messages:
    34
    Likes Received:
    0
    Paul your reply sounds about right as the day the fault started I had unblocked the window wash jets
     
  6. chrisash32

    chrisash32 Member

    Joined:
    Nov 10, 2009
    Messages:
    573
    Likes Received:
    1
    same happened to mine, needed a new washer unit in the rear. the old one was full of water!
     
  7. kashiskash

    kashiskash Member

    Joined:
    Jan 22, 2009
    Messages:
    34
    Likes Received:
    0
    how much was you stung for Chris?

    Also just drove to work and the dashboard computer is flagging up error tailgate open now
     
  8. chrisash32

    chrisash32 Member

    Joined:
    Nov 10, 2009
    Messages:
    573
    Likes Received:
    1
    Yeh, thats sounds like it! Mine was fixed by the dealer i bought the car off as i picked up on it days after getting the car, so i don't know how much it cost.
    Give PJMspeedy a shout on here, he should be able to get you a price on the part needed.

    In the meantime, i would be tempted to take the boot cover off, dry out the components as best you can and try not to use the rear wash wipe..
     
  9. cheekeemonkey

    cheekeemonkey Member

    Joined:
    Dec 30, 2007
    Messages:
    128
    Likes Received:
    0
    I had a similar issue - stripped out the rear trim and the rear washer was spraying washer fludi allover - the seal inside therear motor had gone - circuit board corroded and all the connections were shorting - that's why my tailgate wasn't registering as shut even though it was.

    £45 for an '06 one from a scrap dealer and a few bits of cloth and cotton buds to dy out all the connections and bingo all sorted - I can even see out of my rear screen now!!

    Edit:pJM quoted me around £85 which was still way cheaper than the stealers!
     

Share This Page