1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rear wash wipe intermitant? faulty motor??

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by rich1973, Jan 27, 2011.

  1. rich1973
    Offline

    rich1973 New Member

    Joined:
    Aug 16, 2010
    Messages:
    18
    Likes Received:
    0
    [Jan 27, 2011]
    Hi, my rear wiper has decided to go faulty just weeks before we drive down to the Alps.

    Anyone tried stripping one down before or had any experience in repairing?

    Garage reckons its a faulty motor? i'm not sure, is there some kind of ecu / electronics that operate it & if so, where are they?

    The wiper sometimes does full sweeps, other times stops in various places.

    Thanks,

    Richard
    #1
  2. Ads

    Ads

    [Sep 20, 2014]

  3. benr
    Offline

    benr Member

    Joined:
    Jan 21, 2008
    Messages:
    819
    Likes Received:
    0
    [Jan 27, 2011]
    On my old A3 mine used to get stuck for a second on the sweep back, always in the same place.

    I pulled it out, took it apart and cleaned and greased all the moving bits. It was filthy and gunked up. Put it all back together and it worked fine till I sold the car a couple of years later probably still working now.
    #2
  4. rich1973
    Offline

    rich1973 New Member

    Joined:
    Aug 16, 2010
    Messages:
    18
    Likes Received:
    0
    [Jan 27, 2011]
    ace will try that, not had time recently but will have soon. should have thought of that myself after xx years of fixing tvr's...

    richard
    #3
  5. nickf
    Offline

    nickf New Member

    Joined:
    Oct 25, 2009
    Messages:
    25
    Likes Received:
    0
    [Feb 1, 2011]
    Well mines died completely, has power so looks like a new ones needed. Anyone any odea of cost?
    #4

Share This Page