1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rear light problem

Mindak Jan 2, 2014

  1. Mindak

    Mindak Active Member

    791
    130
    43
    Hi guys, recently when starting up my car I'm getting a bulb warning (rear left turn signal) but when putting it on they flash fast for around 5 flashes then return to normal?

    upon looking at the light today I can see water in there and came pouring out when removed (this applied for both sides)
    the clusters seem to be separated which I see is quite common! Can these be resealed in any way?

    also I see some of the contacts are corroded which I'm guessing is causes by the leaking clusters!
    And lastly I think I'm missing a couple of grommets that hold the clusters to the bodywork, can these be easily sourced?

    thanks guys?
     
  2. Fritz-s3

    Fritz-s3 New Member

    23
    0
    1
    Hi mate, i had this problem with my 2011 s3. Rang audi and they replaced rear cluster under warranty. Seems like quite a common problem which shouldn't happen with a premium brand car.
     
  3. Mindak

    Mindak Active Member

    791
    130
    43
    My car is a 2007 but is under warrantee from the place I bought it, should I phone audi direct or did you write to them?

    Thanks
     
  4. Fritz-s3

    Fritz-s3 New Member

    23
    0
    1
    I went direct to audi mate because it was still under its 3 year warranty. Worth a try though, failing that i don't think their too expensive for new cluster.
     
  5. a6_chris

    a6_chris Well-Known Member

    1,883
    160
    63
    If you didn't buy it from Audi then there's no point in ringing them.

    Ring the place you bought the car from.
     
  6. Mindak

    Mindak Active Member

    791
    130
    43
    It was taken in Px at audi and sold on another forecourt on their behalf! So still through them luckily! Rang them and am taking it down there in the morning for them to assess!
     
  7. Mindak

    Mindak Active Member

    791
    130
    43
    Took the car to audi today and they confirmed that the rears are letting in water so causing a short triggering the warnings so will need replacing! I also mentioned about my key being iffy as doesn't always work on the button (I tried battery) so they also confirmed the key is faulty and will need replacing, they are phoning me Monday when the work has been authorised and parts ordered!
    And best of all they treated me to tea and biscuits while I was waiting! Lol
     
  8. Mindak

    Mindak Active Member

    791
    130
    43
    Update time - Audi were very helpful and called to confirm the work had been authorised to be carried out free of charge so went back Thursday to have a new set of rear clusters and I've been fault free since, also gave the car a good clean which saved me doing it!
    Just waiting for the key to be in so I can go get it coded!

    Overall very happy with audi's customer service!
     

Share This Page