1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rear door speakers

Discussion in 'In-Car Entertainment' started by beameup, May 10, 2009.

  1. beameup

    beameup New Member

    Joined:
    Apr 3, 2009
    Messages:
    22
    Likes Received:
    0
    Hi everyone

    I have a problem with the rear door speakers on my 18T 2003 advant 163 sport.The head unit is the symphony non bose with cd stacker .The rear door speaker are not working as they should as one does not work and the other sounds distorted and clicks and pops.My question is are this speakers off the amp or head unit and has anybody had any sort of similar problem and how to fix

    Many thanks:rtfm::rtfm::rtfm:
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. AndyMac

    AndyMac Moderator
    Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    39
    The rears are driven off the sub amp in the boot on the non Bose setup (drivers side cubbyhole). Chances are the amp could be playing up, or the speakers are blown. Easy enough to check. Connect a multimeter set to ohms across the rear connection on the one that doesn't work, and see if you get a circuit reading 4 ohms, or connect a AA battery across the connection and see if the speaker pops. The Bose amps are notorious for dry solder joints but not aware of similar problems with the non Bose amp. Does the sub work OK? (or as OK as it can work!)
    You can also get issues with the door pillar connection on the feed to the speakers, but this mainly affects the fronts.
    I have a spare amp from our Avant which I am happy to send you so you can do a quick swap to see if it cures the issue. Just let me know.
     
  4. beameup

    beameup New Member

    Joined:
    Apr 3, 2009
    Messages:
    22
    Likes Received:
    0
    Thanks Andy Mac will try when I get a chance and will post outcome:anbet:
     

Share This Page