1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rear brake pads incorrectly fitted?

wuta3 Mar 31, 2014

  1. wuta3

    wuta3 Well-Known Member

    1,124
    347
    83
    Ok, so got my rear disks and pads done. I spotted the wear on the disk looked "off", much more wear on
    the inner edge than i'd expect. I suspect the wrong pads have been fitted or incorrectly fitted. Want some
    group opinion before I go and kick off:

    brakes1.jpg
    brakes2.jpg

    The backing plate is damn near touching the hub, same on both sides.

    Full sized images: brakes - Imgur
     
    Last edited: Mar 31, 2014
  2. ahtcap

    ahtcap Member

    181
    22
    18
    Dangerous!!!
    wouldn't be happy with that.
     
  3. wuta3

    wuta3 Well-Known Member

    1,124
    347
    83
    anyone else wanna chip in? They feel fine, I just don't know if they are incorrect for sure
     
    Last edited: Mar 31, 2014
  4. vroomtshh

    vroomtshh Active Member

    362
    49
    28
    Looks correct to me
     
  5. Staz

    Staz is a retronaut Staff Member Moderator VCDS Map User

    6,206
    64
    48
    They look like they're fitted correctly but are they the right pads?
     
  6. welshd1k

    welshd1k Member

    147
    4
    18
    look like wrong pads to me ill go look at mine now
     
  7. MrLapou

    MrLapou Well-Known Member

    1,233
    121
    63
    Yip. Looks like wrong pads to me to.
     
  8. wuta3

    wuta3 Well-Known Member

    1,124
    347
    83
    That's what I thought, the backing plate lobes are in the clips and caliper, but the plate extends too far inwards and the friction material seems to be seated in the wrong place.
     
  9. ahtcap

    ahtcap Member

    181
    22
    18
    What was the outcome?
     

Share This Page