1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rear brake light help needed

Discussion in 'A3/S3 Forum (8L Chassis)' started by Grale1, Sep 26, 2012.

  1. Grale1
    Offline

    Grale1 Member

    Joined:
    Jun 21, 2012
    Messages:
    639
    Likes Received:
    23
    [Sep 26, 2012]
    I just put preface lift lights on my car this afternoon, bought second hand. The problem I have is the drivers side all works fine, the passenger side the brake bulb was blown so changed it using one from old cluster, and it doesn't work (brake light) now if I put the light unit from drivers side to passenger side the passenger side works and drivers side doesn't, I've tried all light units and its all the same out come, I've checked the brake fuse and that's fine, now I'm stuck to where else to go,

    any help would be great, a3 1.8 AGU if this helps
    #1
  2. Ads

    Ads

    [Oct 23, 2014]

  3. Grale1
    Offline

    Grale1 Member

    Joined:
    Jun 21, 2012
    Messages:
    639
    Likes Received:
    23
    [Sep 26, 2012]
    Could this be the brake pedal switch?
    #2
  4. Grale1
    Offline

    Grale1 Member

    Joined:
    Jun 21, 2012
    Messages:
    639
    Likes Received:
    23
    [Sep 26, 2012]
    Anyone with any suggestions? Kinda need some brake light lol
    #3
  5. phil miller
    Offline

    phil miller Member

    Joined:
    Sep 9, 2012
    Messages:
    845
    Likes Received:
    83
    [Sep 26, 2012]
    If the brake lights work on the drivers side and not the pass side, and if when the drives bulb holder is in the pass side it works then it can only really be the bulb holder is faulty, its late and im tried i hope i have read it correctly????
    #4
  6. Grale1
    Offline

    Grale1 Member

    Joined:
    Jun 21, 2012
    Messages:
    639
    Likes Received:
    23
    [Sep 26, 2012]
    I'm still trying to find info on what it could be, thanks for your in put tho mate, I've tried 3 different bulb carriers, think ill have to take it to garage and get them to put the vcds on and see
    #5
  7. pthackeray22
    Offline

    pthackeray22 Member

    Joined:
    Aug 11, 2012
    Messages:
    92
    Likes Received:
    0
    [Sep 27, 2012]
    did they work previously?
    #6
  8. Grale1
    Offline

    Grale1 Member

    Joined:
    Jun 21, 2012
    Messages:
    639
    Likes Received:
    23
    [Sep 27, 2012]
    I got my light problem sorted, it turned out to be a bad brake light bulb, had 4 bulbs none worked till new put in, it's always the simple things lol,
    #7

Share This Page