1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Really annoying Squeaking noise

Discussion in 'A3/S3 Forum (8L Chassis)' started by S3 Nattie, Jul 14, 2011.

  1. S3 Nattie
    Offline

    S3 Nattie Quattro ist für sissies

    Joined:
    May 19, 2009
    Messages:
    1,600
    Likes Received:
    7
    [Jul 14, 2011]
    Hi guys, my cars has got a really loud constant squeaking noise coming from the N/S/F wheel. There is also a slight rattle/grating noise coming from that side too.

    So far ive replaced the wheel bearing, took the piston out and cleaned it up etc, cleaned all the sliders and calipers, re greased the cv joint and changed the pads around with the the O/S/F and its still the same. The pads have a lot of life left in them and disc look ok and not warped as far as I can tell.

    The squeaking noise is there once the disc/pads are warm. Any info would be great thanks.
    #1
  2. Ads

    Ads

    [Sep 19, 2014]

  3. S3KO4
    Offline

    S3KO4 Member

    Joined:
    Aug 15, 2009
    Messages:
    850
    Likes Received:
    2
    [Jul 14, 2011]
    I don't know why you would think it's the discs and pads! I would have thought it's more like the suspensions top mounts, look at them see if there is a gap then it's most likely to be the culprit
    #2
  4. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    729
    [Jul 14, 2011]
    Copperslip on the back of the pads?
    #3
  5. S3 Nattie
    Offline

    S3 Nattie Quattro ist für sissies

    Joined:
    May 19, 2009
    Messages:
    1,600
    Likes Received:
    7
    [Jul 16, 2011]
    Its not a rubber type squeak, more like a whistle type squeak if that makes sense. My top mounts are few months old too and dont think it would explain the rattle im experiencing too.

    The back of the pads and sliders are all greased up Dave, really strange what it is.
    #4
  6. S3 Nattie
    Offline

    S3 Nattie Quattro ist für sissies

    Joined:
    May 19, 2009
    Messages:
    1,600
    Likes Received:
    7
    [Jul 16, 2011]
    I had a thought that my ABS sensors could be rubbing very slightly on the hub rings because my ABS/TC goes mad sometimes if I hit a bump at 10mph.

    The only thing is the squeak comes once the brakes get hot so not sure if the ABS sensors would cause this but going to have a look at them anyway.
    #5
  7. S3 Nattie
    Offline

    S3 Nattie Quattro ist für sissies

    Joined:
    May 19, 2009
    Messages:
    1,600
    Likes Received:
    7
    [Jul 17, 2011]
    Any more suggestions anyone, really annoying the **** out of me.
    #6
  8. JoeD
    Offline

    JoeD Member

    Joined:
    Aug 27, 2009
    Messages:
    537
    Likes Received:
    10
    [Jul 17, 2011]
    Any progress dude?
    #7
  9. S3 Nattie
    Offline

    S3 Nattie Quattro ist für sissies

    Joined:
    May 19, 2009
    Messages:
    1,600
    Likes Received:
    7
    [Jul 17, 2011]
    Nope not yet bro. Going to try and get it on my friends ramp in the week.

    This is the final straw with this car. As soon as this little problem is sorted its gone.
    #8

Share This Page