1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

REAL HEAD MELTER..

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by BASS 666, Sep 7, 2011.

  1. BASS 666
    Offline

    BASS 666 BMW aye right dead on..

    Joined:
    Sep 23, 2010
    Messages:
    463
    Likes Received:
    1
    hi guys. got a real melter of a problem. a few wks ago i started my car, it starts on the button with one turn of the key since i bought it four yrs ago but this time it turned over about seven times before starting. so this has been happening all the time now, and now and again it starts first turn but not that often. i thought it was drawing in air somewhere so i checked all the fuel pipes and put some propper fuel hose clamps on all the pipes. i changed the one way valve on top of the fuel filter and the filter aswell. i took the lift pump out of the fuel tank and and cleaned the filter on the bottom and checked that it was working and put it back in. the fuel relay is working and im happy its not drawing air. the starter and battery are like new and it turns over very fast. i changed the injector wiring loom today and i fitted a reconditioned fuel pump on the back of the head. when you rev the engine and turn it off and then start it right away 7 times out of 10 it starts first time but when you leave it a while it wont start unless it turns over for a bit. cheers guys.
    #1
  2. CMD
    Offline

    CMD Pointing Forward's!!!!!!!!!

    Joined:
    Nov 22, 2008
    Messages:
    3,016
    Likes Received:
    17
    I had starting problem's when i first bought mine . I had the battery tested before start up and whilst is was running, the battery was losing it's charge over 24 hours (slowly) stuck in a new battery all is still good
    #2
  3. BASS 666
    Offline

    BASS 666 BMW aye right dead on..

    Joined:
    Sep 23, 2010
    Messages:
    463
    Likes Received:
    1
    had the battery tested and its fine mate
    #3
  4. quattrojames
    Offline

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,888
    Likes Received:
    475
    Have you tried the starting with your lights on trick?
    #4
  5. BASS 666
    Offline

    BASS 666 BMW aye right dead on..

    Joined:
    Sep 23, 2010
    Messages:
    463
    Likes Received:
    1
    no james, whats that all about ?
    #5
  6. quattrojames
    Offline

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,888
    Likes Received:
    475
    I don't think it's official, but there are several users on here who will confirm my ludicrous suggestion!

    The light switch is somehow connected to the starting circuit, when you go to start the car put your headlights on first. If it starts better then replace the switch. Strange, but true.
    #6
  7. BASS 666
    Offline

    BASS 666 BMW aye right dead on..

    Joined:
    Sep 23, 2010
    Messages:
    463
    Likes Received:
    1
    if it works i will go mad. the money i have spent..
    #7
  8. quattro tony
    Offline

    quattro tony Member

    Joined:
    Sep 4, 2010
    Messages:
    167
    Likes Received:
    0
    Have you had a diagnostic test done? when i first got mine it has starting probs and had a couple of faults logged coolant temp sensor and glow plug fault, changed these and it always starts on the button.
    #8
  9. BASS 666
    Offline

    BASS 666 BMW aye right dead on..

    Joined:
    Sep 23, 2010
    Messages:
    463
    Likes Received:
    1
    holly f... i dont believe it the headlight switch trick done the job. thanks james. iv been a mechanic for 27 yrs and im always learning something new but this takes the piss big time. someone should make this a sticky..
    #9
  10. quattrojames
    Offline

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,888
    Likes Received:
    475
  11. rjm180
    Offline

    rjm180 Member

    Joined:
    Mar 28, 2009
    Messages:
    475
    Likes Received:
    12
    Thats why you're the Mod, James.
    #11
  12. Grangey.
    Offline

    Grangey. Member

    Joined:
    May 17, 2011
    Messages:
    226
    Likes Received:
    2
    yeah ive got the same problem (light switch), it is a common fault and is on audis back end system, replacement switch and fitting is about £90 (99% cost is the switch), im not bothered, i just start it with my side lights on every time :)
    #12
  13. stu_m
    Offline

    stu_m Active Member

    Joined:
    Oct 25, 2009
    Messages:
    1,442
    Likes Received:
    36
    i had the same problem with the headlight switch and for a year or so was always turning side lights on to start

    now it seems to have rectified itself and start first turn without lights!!
    #13
  14. manosskali
    Offline

    manosskali Member

    Joined:
    Aug 2, 2011
    Messages:
    34
    Likes Received:
    0
    I think I ve got the same problem - the car most of the time starts first time but sometimes it just won't fire up. When I put my lights on, initially it sounds like it won't fire up again, but eventually (after 4-5 turns) it does - but still very hesitantly.. Is this the behaviour others are experiencing? Is the only solution a new light switch or has anybody managed to fix it somehow? Thanks!
    #14
  15. Grangey.
    Offline

    Grangey. Member

    Joined:
    May 17, 2011
    Messages:
    226
    Likes Received:
    2
    ^^ doesnt sound like it, the symptoms I experience is with no lights on- it take about 3-5 sections (or around 8-10 engine rotations) to get the engine to fire, turn the sidelights on and its a .5-1 second (or about 2 rotations) to get the engine to fire.
    #15

Share This Page