1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. SeanTFSI

    SeanTFSI Sticking with Audi

    78
    48
    18
    Hope someone can help me. I installed a RaceChip into my car last night and have had a few issues. First installation, the turbo definitely wasn’t doing anything and the car was running purely on the engine. Took car home, took it out and hooked it back up normally and then the check engine light came on, engine and turbo both working fine.

    I believe this to be a software issue, and confirmed this by installing the chip back in the car and the check engine light came off. Almost as if the ECU knew there was a problem, but now believes it to be fixed again.

    Took it for a drive after this and gear 1 was phenominal, telling me the chip had worked. After this though gear 2 and 3 were so sluggish, as if the turbo spooled very slowly. Messaged the company and left it for the night.

    This morning after no changes, I started the car and the Check Engine Light has come back on. Seems to be something very wrong with the connections on this chip in some way or another.

    Has anyone fitted one of these before and encountered this, any ideas on any solutions?
     
  2. Booboo

    Booboo Member

    111
    15
    18
    buy cheap buy twice I have a TMC tuning box fitted. It plugs in to map sensor, cam position sensor and throttle position sensor. I bet the race chip plugs in to only one.
     
  3. SeanTFSI

    SeanTFSI Sticking with Audi

    78
    48
    18
    It cost £230, might be cheap in comparison but seemed good at the time, 50hp increase.

    Yes, it plugs into boost only but I don't understand why that would be bad? It connects to boost/turbo.

    I went the garage and hooked it up, showed an error stating circ high input, the guy said it could mean a few thigs, any ideas?
     
  4. Lavis89

    Lavis89 Well-Known Member Regional Rep Team Sprint Audi S4 Audi A3

    1,920
    756
    113
    I'm guessing seeing as it's just plugging in to the boost the car is running too lean for the ECU to adjust which is what will be causing your CEL.

    That's just spitting in the wind though, without actually being in the car and seeing the "racechip" it's hard to diagnose what's happening.

    Not worth cheaping out when tuning a car, could cause a whole lot of damage just by trying to save a hundred quid or so.
     
  5. SeanTFSI

    SeanTFSI Sticking with Audi

    78
    48
    18
    I honestly wasn't aware i was cheaping out...thought it was just a typical price!

    The CEL wasn't a concern as I knew it was a software warning. The turbo completely shutting off got me thinking poor connection.

    The chip works after the ECO so it never knows it has been installed. Google Racechip Pro 2 if you want to see it
     
  6. Lavis89

    Lavis89 Well-Known Member Regional Rep Team Sprint Audi S4 Audi A3

    1,920
    756
    113
    Just had a little read up and people seem to rate them, I haven't heard of them personally so thought it might have been some cheap Chinese POS. Does sound like the real deal. I'm still more a fan of ECU mapping rather than plug in gadgets. You may have a underlying problem that the racechip is flagging up.
     
  7. SeanTFSI

    SeanTFSI Sticking with Audi

    78
    48
    18
    The car doesn't feel like it has an issue, very clean drive up until this chip... The reason I chose it is because if I sell the car i can just remove it easy.

    The car threw up no errors when tested but when chip connectd gave off the Turbo high input.
     
  8. Chris90

    Chris90 Active Member VCDS Map User

    620
    226
    43
    The chip will be a resistor in a box and will just request more boost off the turbo by increasing the duty values.

    The ECU is smart enough and will see that a 'overboost' condition is there after is sees pressure over a certain threshold given the RPM and the expected values. Once it sees the overboost, attempts to prevent it by shutting things down, such as throttle body closing and if that fails, will drop the engine into limp mode and throw a engine light.

    Boxes might have worked 10years ago on basic diesels, but these days, too many protection maps in the ecu to simply plug a box between 1,2 or 3 sensors and expect a reliable power increase
     
  9. SeanTFSI

    SeanTFSI Sticking with Audi

    78
    48
    18
    Considering my car is an 09 and they sell it for a B8 specifically, wouldn't you think they at have this covered?

    What you suggest is logical though, as the error suggests but more details may disprove this. The chip supposedly is off when car is idling, so in theory is invisible to the ECU. CEL comes on start-up and the error found while idle.

    When it partially worked, gear 1 has a lot of pull but it failed after this. Wouldn't an ECU be consistent in behaviour and simply never allow it?

    Thank you so far, way more help than RaceChips Customer Service
     
  10. Booboo

    Booboo Member

    111
    15
    18
    This simply isn't true I had my TMC box on my Audi A1 1.4 TFSi for over 4 years without a wiff of trouble. I was so pleased with it when I swapped to the 225bhp 2.0 TFSi I sent it back to be remapped & had a new loom for the A4. I now get over 260 bhp
    I have had nearly 5 years of reliable power increase.
     
  11. Lavis89

    Lavis89 Well-Known Member Regional Rep Team Sprint Audi S4 Audi A3

    1,920
    756
    113
    Yea quite a few people use these boxes now, some of them are pretty fancy.

    Either the box you've got is duff or there is a issue with your car that the extra power has flagged up. See if you can swap the box for a new one, if a new box doesn't fix it then either the box itself is trash or your car has a issue. Does sound like the box is just causing the car to overboost which will cause a CEL and limp mode
     
  12. SeanTFSI

    SeanTFSI Sticking with Audi

    78
    48
    18
    As the box is designed to work with the car specifcally to order, I imagine maybe if you're correct I was sent the wrong model. I honestly wouldn't mind so much but RaceChip are being so difficult to work with. I asked them for a call they agreed but didn't ring, ignored me on Facebook, haven't replied to my emails... They're a legit company for sure but seriously poor customer service. I've asked for a refund, I really, really want to boost my car but if they won't work with me when there's an issue early on, imagine if it causes engine damage.
     
  13. scotty76

    scotty76 Well-Known Member Team Phantom Audi S4

    3,182
    1,929
    113
  14. SeanTFSI

    SeanTFSI Sticking with Audi

    78
    48
    18
    Yeah, I did it on a credit card just for this reason. I'm confident I'll get a refund, I think they're just stalling me though. I know they're not a scam company just seem to be poor at helping. I'm kind of reluctant to remove it as I want them to have an answer so I can use it... This morning they said:

    "with pleasure we will call you today whenever you want. I'm sure that we can help you to fix the problem and we are sure that our product isn't faulty.

    If the check engine light appears without RaceChip and cable installed in your car you have to start the car for 5-6 times again and again and drive few kilometers.

    In addition, it is very important that you follow the installation steps to get no fault. Please confirm that the installation was made exactly as it follows: 1) Open the bonnet/hood 2) Close all doors and make sure everything inside the car is switched off. 3) lock the car 4) Wait 15 minutes 5) Install the RaceChip If your car has a Keyless go system, the key must be at least 30m away from the vehicle.

    If that doesn´t help, please send us a picture of the entire engine without cover and one picture of each connection, where we can see the installation as clear as possible. The connections between the cable and your car have to click. "

    Re-iterated the fault it came up with to them as that proves connections are fine.
     
  15. SeanTFSI

    SeanTFSI Sticking with Audi

    78
    48
    18
    So I fixed the fault with the chip. Turns out it's as simple as a non fitting connection. Did a bit of twisting, pushing, bending and cutting plastic and finally click!

    Took it for a test drive and oh boy is it smooth, so happy my chip works now, just a shame the clip wasn't designed to fit properly. Give it a few weeks of use and I'll decide if to recommend
     
  16. Chris90

    Chris90 Active Member VCDS Map User

    620
    226
    43
    You sure its not true? There are a tonne of overboost tables in modern VAG ECUs and typically they set to 400mbar / 5.8psi so anything over that the ECU will trip out. Taking into account the boost requested tables aswell...or should I say load to be more precise.
     
  17. Booboo

    Booboo Member

    111
    15
    18
    Yep sure it's not true I've ran a box for 5 years on my TFSi's without a single problem. If they over boost the box is set too high, and needs to be turned down. Simples. This isn't hearsay these are facts as I have seen them on my A4 and my son 3.0 TDi which has a DTUK Box on it.
    If he booted his too hard it did over boost so we turned it down 1 click. Sorted
     
  18. SeanTFSI

    SeanTFSI Sticking with Audi

    78
    48
    18
    I did research into mine and its a pretty basic setup. The chip inside has stages, something like 10 - 12 groups set up between two stages.

    Altering a stage alters the time and if you find its not quite right they suggest to alter one stage by one digit at a time, but they send you what they believe is the best set up for your car.

    Now that mine has been in and done some motorway miles i definitely think it's right to my car. I have no worry it isn't and don't think it'll overboost. It feels very consistent and climbs revs smoothly. I would say they are designed around your car and not generic.
     
  19. SeanTFSI

    SeanTFSI Sticking with Audi

    78
    48
    18
    Update on my RaceChip. I've had it for some time now and it is highly recommendable. The reason I went for it is that it isn't permanent, so I can just remove it for whatever reason necessary.

    Overall my turbo is a lot cleaner in performace, torque is through the roof and my milage is so much better. I can roll to work at 35mph in 5th gear and previously my gauge would say 10 miles of fuel used there and 10 miles back, on a good day now it'll say 5 used total or normally 10 used total.

    http://aklam.io/dCYXM8 - Referral link for those interested!

    I did have teething problems, I had to hack one of the connections as there was too much plastic but otherwise all good!
     
    xpoweruk likes this.
  20. Jared Miller

    Jared Miller New Member

    1
    0
    1
    Sean, I thought i was literally the only person in the world who has a connection issue. My chip arrived and I have a 2014 A4 2.0T TFSI. The instructions are no help as they supplied 2 connection points. One for boost and the other manifold. I can connect the charge pipe connection but clueless where the other goes. What did you modify to make work? Where the heck did you plug in? I'm so upset I can't use this..please help!
     
  21. Just Rob.

    Just Rob. Moderator Staff Member Moderator Team Daytona TFSI Owners Group Team V8 VCDS Map User Gold Supporter Team Brilliant Black Audi RS4 quattro Audi A4 Audi Avant Owner Group S-line owners group Manual

    5,160
    1,819
    113
    I currently run a B7 2.0tfsi special edition (220 BUL) and also was considering the race chip option and to be honest they did have a lot of good feedback and if one wants a quick and easy removal setup they sound ideal.
    I'm still on the fence at moment between going the revo ecu remap route at £500 or plug in box £200, the ecu remap maybe better route but not sure the racechip can be ignored completely even though they seem to get a lot of flack , some of it from users and a lot from others that just don't like them.
    A few things did worry me with race chip which were as follows, I emailed them for info and data on the chip for my 220BUL engine and never had a reply, also they make a big thing about covering engines if they go bang which kinda made thing that they have been having isuues in that area and want to cover themselves.
    Also there customer services seems to be a bit on the poor side or maybe just rubbish would be a better description.
    I think having looked at the alternatives, pros and cons, the racechip route maybe worth a go and at worse case it would eliminate that technology in the future for my car.
    Hope you get it sorted chaps, I may just give one a go...i'll see .
     
  22. Booboo

    Booboo Member

    111
    15
    18
    I have a TMC tuning box on my B8 2.0 TFSi figures claim from 225bhp to 261bhp. I sent the box back to them after I'd sold my A1 & had it remapped and a new loom for £80+vat. So I'd say buy any TMC box off ebay & then send it to them & get it mapped for your car.
    I ran it on my A1 for 4 years & now had it on my A4 since April.
     
  23. Booboo

    Booboo Member

    111
    15
    18
    If its like my TMC tuning box, as you said ones goes to the throttle position the other goes to the cam position sensor. This is toward the bulk head on the right hand side near the top.
     

Share This Page