1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Puzzling oil light problem

Joshstan Apr 22, 2014

  1. Joshstan

    Joshstan Member

    180
    17
    18
    Hi all this is my first thread here I have had my nice shiny s3 for about a week now and after 2days I had the red dripping oil can
    being fairly familiar with the vag 1.8t engines (last car was a mk4 golf gti) I had the sump off cleaned it up and fitted a new oil pump and pickup pipe along with full oil and filter change after all of this I start the car and gently run it to 2k rpm for a few seconds and the bloody light comes back on I really don't know what else to do
    is there a way I can bypass the pressure sender (just to be able to rule out a wiring fault)
     
  2. Joshstan

    Joshstan Member

    180
    17
    18
    Forgot to mention it is a 1999 apy engine code
     
  3. Lewis583

    Lewis583 Active Member VCDS Map User

    956
    91
    28
    You could disconnect the spade terminal from the pressure sender and earth it while revving. Though I only suggest doing that after you have mechanically checked the oil pressure with a gauge.
     
  4. Joshstan

    Joshstan Member

    180
    17
    18
    Thanks for the reply I'll have to go find a pressure gauge tomorrow and give that a go also my VAGCOM cable should arrive in the next 2 days so hopefully I can find the cause of this I'm in over £150 already trying to sort this lol
     

Share This Page