1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems with alarm and radio in safe mode

Discussion in 'A3/S3/Sportback (8P Chassis)' started by squarebush80, Jan 24, 2013.

  1. squarebush80
    Offline

    squarebush80 New Member

    Joined:
    Dec 2, 2012
    Messages:
    15
    Likes Received:
    0
    Hi guys, think there is an electrical problem on my a3 2.0 tdi 2005, at first the alarm keeps going off whenever i lock the car, now the radio is in 'safe mode', i have the code but when it gets entered it just keeps jumping back into safe mode. my partner was driving the car the other day with the hazards flashing and they wouldnt go off, the only way to stop the alarm going off is by pressing the towing button on the inside of the door. any help will be appreciated. Thanks.
    #1
  2. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,229
    Likes Received:
    1,220
    Ideally it needs a scan with vcds to ascertain if any faults are constantly popping up.
    #2
  3. squarebush80
    Offline

    squarebush80 New Member

    Joined:
    Dec 2, 2012
    Messages:
    15
    Likes Received:
    0
    Chhers for that, ive had it plugged into vagcom and theres no faults at all, ive been told to disconnect the battery for 30 secs or change the battery in the key fob, ill give them a go when i get home. cheers
    #3
  4. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,229
    Likes Received:
    1,220
    Any luck?
    #4
  5. squarebush80
    Offline

    squarebush80 New Member

    Joined:
    Dec 2, 2012
    Messages:
    15
    Likes Received:
    0
    Have not mate, ive went through all the steps, holding the RDS and scan buttons down, entering the code then holding the buttons again, a radio station flashes up for a split second then goes completely blank, this happens every time, its the same radio station that flashes up. Ill try disconnecting the battery tomorrow.
    #5
  6. squarebush80
    Offline

    squarebush80 New Member

    Joined:
    Dec 2, 2012
    Messages:
    15
    Likes Received:
    0
    Had another go there, this time with the key out the ignition, the radio came on and i could change the stations, play a cd the i turned the ignition on and the radio went back to safe mode. i also tried leaving the stereo on (with key out ignition) and the radio cut off after about 30 seconds and went back to safe mode. GRRRRRRR!!!!
    #6
  7. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,229
    Likes Received:
    1,220
    I wonder if its got an issue recognising its connected to the car as such, as it will throw it into safe mode if it doesnt recognise the car it was last attached to, it needs diagnostically checking with possibly some wiring checking, maybe some water has got in somewhere.
    #7
  8. squarebush80
    Offline

    squarebush80 New Member

    Joined:
    Dec 2, 2012
    Messages:
    15
    Likes Received:
    0
    Ive had it diagnosed with vagcom and no faults are showing up, im baffled as why i can get it off safe mode and change the channels on the radio no problem them as soon as i turn the ignition on it goes back into safe mode, im gna get the keys to take the radio out and check for an signs of water getting in. Thanks for your reply
    #8

Share This Page