1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems, any advice welcome

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Gaz!, Oct 21, 2011.

  1. Gaz!
    Offline

    Gaz! Member

    Joined:
    Jan 28, 2009
    Messages:
    148
    Likes Received:
    16
    Two problems, can anyone shed any light please?

    I have a 1.9tdi 130 sport, the brake pad warning light came on (fronts only as rears dont have the sensors) so replaced the pads. As youd expect the warning light on the DIS went off, after a jurney of 15 or so miles the light came back on. After whipping the wheels off again the pads are fine anf the sensors are conected.

    So I disconected both and reconected, still the same warning light. Now I have the sensor disconected (open circuit) this should turn the light off as the system is open circuit, the lamp should only come on when the circuit is closed, ie, the pad wears and the contacts touch the disc. I have the lamp on no matter what I do????

    Secondly, I have a rattle, it has got progressivley worse over the last few months, I have had the front wheels off, checked all bushes everything I can think of. Today I took the car to Kwik fit (would never normally) they put the car on the shaker pad and found nothing.

    The rattle occurs when impacting potholes ect. It's not suspention related and going over bumps such as speed bumps and the susspention in either in compression or extention, no noise. It's a metalic noise and sounds as if something is realy loose. Please someone shed some light on this it's doing my head in.
    #1
  2. quattrojames
    Offline

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,888
    Likes Received:
    475
    Is your brake fluid level ok?

    The rattle isn't something trapped on top of the undertray is it?
    #2
  3. Gaz!
    Offline

    Gaz! Member

    Joined:
    Jan 28, 2009
    Messages:
    148
    Likes Received:
    16
    Brake fluid is at its max and have had the undertrays off many times to look for something loose.

    Im out of ideas mate, seriously conssidering selling as the noise is mega anoying, my mate calls my family the clangers now after we drove past him clanging and rattling...
    #3
  4. Mike B
    Offline

    Mike B Member

    Joined:
    Jul 10, 2007
    Messages:
    774
    Likes Received:
    8
    Are the new pads rattling in the carriers?Have had this on rears and it sounds really loud as you hit a bump.
    #4
  5. quattrojames
    Offline

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,888
    Likes Received:
    475
    I have a similar problem with my low pad light being on intermittently at the moment. The pads are fluid are fine, I've not tried to bypass it yet, it started about the same time as my light switch started playing silly buggers, so I have a sneaking suspicion they might be linked...

    If a new switch doesn't resolve it then I'll by pass it and see what happens.
    #5
  6. Turkster
    Offline

    Turkster Bro.Paul 2.5TDI Quattro Sport

    Joined:
    Dec 11, 2007
    Messages:
    2,718
    Likes Received:
    29
    the plug backwards from the pad may have a nick in it coursing the short circuit, have a inspection there, the noise i cant help you with unless you pass by me in Northampton as its hard to tell from behind a screen,
    #6
    quattro tony likes this.
  7. quattro tony
    Offline

    quattro tony Member

    Joined:
    Sep 4, 2010
    Messages:
    167
    Likes Received:
    0
    Disconnecting the plug off the sensor wire wont turn off the light, have you carefully inspected the warning wires , especially the muliplug for and corrosion, common this, when you replaced the pads first when the light came on were the pads worn to metal?
    Regards your rattle, If you get a garage who knows what they are doing ( except kwik fit )(imho) to carefully check all the balljoints , and underside for any problems,you might find the cause . Rattling pads are a posibility, Ive come across this too, Did the rattle start ever since you changed the pads?:think:
    #7
  8. quattrojames
    Offline

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,888
    Likes Received:
    475
    Does it rattle when you brake? If so, then it won't be the pads.
    #8
  9. deanski
    Offline

    deanski wax on, wax off

    Joined:
    May 20, 2010
    Messages:
    373
    Likes Received:
    6
    I have rattling pads and its a proper pain. I also had the brake light prob and it was the brake light switch.
    #9
  10. swarcup
    Offline

    swarcup Well-Known Member

    Joined:
    Sep 9, 2009
    Messages:
    1,287
    Likes Received:
    37
    this may sound weird but the metalic knocking noise. Does it sound like a bad creaking noise when you set off and stop, the faster you start the worse it is. and as its got worse has it started knocking randomly but at low speeds. this was what i have just had and after changing all 4 arms ,drop links and track rod ends it turned out to be the engine mount, it was only when i supported the engine and removed the bottom bracket that holds the mount it was obvious, the bottom steel plate which the bottom bolt is fixed to had sheared fully accross and half had fallen out thus resulting in a severe creaky knocking noise. Try lifting the bonnet and then setting off, you can whatch the engine through the gap under the bonnet to see if its lifting excessivly, mine was moving up about 3 to 4 inches so it was a giveaway. hope this helps
    #10
  11. marktdisport
    Offline

    marktdisport Active Member

    Joined:
    Jul 14, 2011
    Messages:
    1,195
    Likes Received:
    15
    doesnt the pad light work opposite to you stated on a audi ?? take your plug off and loop a wire over the 2 terminals then switch on the ignition ??? sure this is how i tested mine dont qoute me for sure it was 6 mth ago when i replaced mine my plug was also cracked and full off water, so repaired my plug and its fixed.... try this when you get 5
    #11
  12. Gaz!
    Offline

    Gaz! Member

    Joined:
    Jan 28, 2009
    Messages:
    148
    Likes Received:
    16
    Holy thread resurection.

    Bringing this back up, I have been out of the country fro 6 months and now back to the nightmare audi.

    I have done what marktdisport said, I bridged both conectors for the wear sensors on the front pads, this turned the light off. So new pads it is.

    The rattle.... I cant see it being the pads? Its a massive rattle, will see what the pad replacement brings. Will also check that engine mount.
    #12
  13. hartey
    Offline

    hartey Member

    Joined:
    Nov 21, 2010
    Messages:
    206
    Likes Received:
    3
    Well? Lol
    #13
  14. Gaz!
    Offline

    Gaz! Member

    Joined:
    Jan 28, 2009
    Messages:
    148
    Likes Received:
    16
    Well..... I have fixed it.

    It was the pads all along, bought a set for front pads from Euro car parts, plugged in and put the light out, so I changed the discs aswell. Took it for a drive and no clanging.

    Im surprised it was the pads clanging in the carriers, it sounded like the anti roll bar was hanging off. The wiring,,, who knows, the old pads were conected up the same way.

    Top tip.... dont buy Halfords pads.
    #14

Share This Page