1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with forge twin take s3

whitex8p Nov 12, 2013

  1. whitex8p

    whitex8p Member

    108
    7
    16
    Had this kit fitted over the weekend and i noticed last night that when you rev the engine in neutral and the revs drops just below 1k the car nearly stalls? cold this be a maf issue?
     
  2. MartayMcFly

    MartayMcFly Booooooost VCDS Map User Gold Supporter

    2,763
    354
    83
    Nearly stalling sounds like it might be a MAF issue, but it should be idling at 800 anyway, so must be quite a drop?
     
  3. whitex8p

    whitex8p Member

    108
    7
    16
    its idles fine its just when you rev it up the the revs drop down it about stalls
     
  4. JamesS4cab

    JamesS4cab Well-Known Member

    1,191
    94
    48
    Check that you got the MAF in the correct way round when you fitted it as its directional and an easy mistake to make........
     
  5. whitex8p

    whitex8p Member

    108
    7
    16
    surely it can only fit in one way? Going to check the maf later on
     
  6. Marshy

    Marshy Settled in Audi RS3

    1,352
    469
    83
    If the maf is the correct way round I'd double check the hose on to the turbo is seated correctly and not lifted on one side.
     
  7. TDI140

    TDI140 Well-Known Member

    1,626
    174
    63
    Got to be a leak somewhere one hose must be loose
     
  8. Marshy

    Marshy Settled in Audi RS3

    1,352
    469
    83
    Yeah that's my thoughts too.
    it must be getting unmetered air so you'd think it has a leak after the maf.
     
  9. JamesS4cab

    JamesS4cab Well-Known Member

    1,191
    94
    48
    The MAF can fit in either way, but one way in it works perfectly, and the other it doesnt work properly and the side affects are generally as you describe. I would also agree with the others that it could be a boost leak. I split a small boost house near the DV and that caused same problems but when i opened the bonnet i could hear it leaking.
     
  10. JamesS4cab

    JamesS4cab Well-Known Member

    1,191
    94
    48
    One other thing - was the Forge new or not? If its s/hand, is the filter clean? Has it been over oiled as that can causing "breathing" issues.............
     

Share This Page