1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with forge twin take s3

Discussion in 'A3/S3/Sportback (8P Chassis)' started by whitex8p, Nov 12, 2013.

  1. whitex8p
    Offline

    whitex8p Member

    Joined:
    Jun 23, 2013
    Messages:
    108
    Likes Received:
    7
    Had this kit fitted over the weekend and i noticed last night that when you rev the engine in neutral and the revs drops just below 1k the car nearly stalls? cold this be a maf issue?
    #1
  2. MartayMcFly
    Online

    MartayMcFly Well-Known Member

    Joined:
    Feb 17, 2009
    Messages:
    2,639
    Likes Received:
    280
    Nearly stalling sounds like it might be a MAF issue, but it should be idling at 800 anyway, so must be quite a drop?
    #2
  3. whitex8p
    Offline

    whitex8p Member

    Joined:
    Jun 23, 2013
    Messages:
    108
    Likes Received:
    7
    its idles fine its just when you rev it up the the revs drop down it about stalls
    #3
  4. JamesS4cab
    Offline

    JamesS4cab Well-Known Member

    Joined:
    Mar 4, 2008
    Messages:
    1,137
    Likes Received:
    87
    Check that you got the MAF in the correct way round when you fitted it as its directional and an easy mistake to make........
    #4
  5. whitex8p
    Offline

    whitex8p Member

    Joined:
    Jun 23, 2013
    Messages:
    108
    Likes Received:
    7
    surely it can only fit in one way? Going to check the maf later on
    #5
  6. Marshy
    Online

    Marshy Active Member

    Joined:
    Nov 7, 2013
    Messages:
    756
    Likes Received:
    166
    If the maf is the correct way round I'd double check the hose on to the turbo is seated correctly and not lifted on one side.
    #6
  7. TDI140
    Offline

    TDI140 Well-Known Member

    Joined:
    May 19, 2011
    Messages:
    1,378
    Likes Received:
    140
    Got to be a leak somewhere one hose must be loose
    #7
  8. Marshy
    Online

    Marshy Active Member

    Joined:
    Nov 7, 2013
    Messages:
    756
    Likes Received:
    166
    Yeah that's my thoughts too.
    it must be getting unmetered air so you'd think it has a leak after the maf.
    #8
  9. JamesS4cab
    Offline

    JamesS4cab Well-Known Member

    Joined:
    Mar 4, 2008
    Messages:
    1,137
    Likes Received:
    87
    The MAF can fit in either way, but one way in it works perfectly, and the other it doesnt work properly and the side affects are generally as you describe. I would also agree with the others that it could be a boost leak. I split a small boost house near the DV and that caused same problems but when i opened the bonnet i could hear it leaking.
    #9
  10. JamesS4cab
    Offline

    JamesS4cab Well-Known Member

    Joined:
    Mar 4, 2008
    Messages:
    1,137
    Likes Received:
    87
    One other thing - was the Forge new or not? If its s/hand, is the filter clean? Has it been over oiled as that can causing "breathing" issues.............
    #10

Share This Page