1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem when indicating!!

Discussion in 'A3/S3 Forum (8L Chassis)' started by Sm3g, Oct 12, 2009.

  1. Sm3g
    Offline

    Sm3g STANDARD S3 (225bhp)

    Joined:
    May 22, 2009
    Messages:
    64
    Likes Received:
    1
    [Oct 12, 2009]
    evening guys

    hope you can shed some light on a problem thats just started happening with my motor?
    basically when i move my indicator stalk to turn left or right,all thats happening is the green arrow light is staying on,on my dash its not making the clicking sound either and the bulb in the headlight is not flashing either on the outside its just staying on untill i move the stalk back to the off position:think:. any ideas what it could be would be a big help!!!!cheers
    #1
  2. Ads

    Ads

    [Dec 25, 2014]

  3. JS1500
    Offline

    JS1500 Howdy

    Joined:
    Sep 28, 2009
    Messages:
    1,167
    Likes Received:
    8
    [Oct 12, 2009]
    Damn, wish I could remember the name of this part... hazard relay?
    Happened to my car when I took it for the test drive, the dealership sorted it quick and easy.

    Edit: Also happened to my MG, again - easy fix.
    #2
  4. Sm3g
    Offline

    Sm3g STANDARD S3 (225bhp)

    Joined:
    May 22, 2009
    Messages:
    64
    Likes Received:
    1
    [Oct 12, 2009]
    thanks mate had a feeling it mite be something to do with a relay,prob best of bobbing to audi then and getting them to source me a new part and il hopefully fix it my self:yes:
    #3
  5. Y83OLK
    Offline

    Y83OLK Hulk Smash!

    Joined:
    Sep 6, 2009
    Messages:
    841
    Likes Received:
    4
    [Oct 12, 2009]
    The indicator relays built into the hazard switch.

    But is a common fault
    #4
  6. Sm3g
    Offline

    Sm3g STANDARD S3 (225bhp)

    Joined:
    May 22, 2009
    Messages:
    64
    Likes Received:
    1
    [Oct 13, 2009]
    how hard is it to fit the new relay? is it a centre console job removing all that?
    #5
  7. metricspaces
    Offline

    metricspaces Member

    Joined:
    Jun 4, 2007
    Messages:
    642
    Likes Received:
    1
  8. Sm3g
    Offline

    Sm3g STANDARD S3 (225bhp)

    Joined:
    May 22, 2009
    Messages:
    64
    Likes Received:
    1
    [Oct 13, 2009]
    thanks mate,that helps loads cheers buddy!!:rockwoot:
    #7
  9. Sm3g
    Offline

    Sm3g STANDARD S3 (225bhp)

    Joined:
    May 22, 2009
    Messages:
    64
    Likes Received:
    1
    [Oct 15, 2009]
    am i right in thinking then,cos mine is a 52reg so its the facelift model,do i just need to pop out them false buttons either side of the traction controll button,then just pull the gloss black plate towards me to get to the hazzard switch,or do i still need to remove my sterio??:think:
    #8
  10. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,659
    Likes Received:
    99
    [Oct 15, 2009]
    I didnt remove my stereo, just the piano black surround. no buttons need to be removed either mate,
    Matt
    #9
  11. Sm3g
    Offline

    Sm3g STANDARD S3 (225bhp)

    Joined:
    May 22, 2009
    Messages:
    64
    Likes Received:
    1
    [Oct 15, 2009]
    or right,how did you manage to prise the piano black plate from around the hazzard switch then?did you have to squeeze something down either side of the plate or something??
    #10
  12. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,659
    Likes Received:
    99
    [Oct 15, 2009]
    I used a table knife with a cloth round it to prevent scratching the trim, if ur firm but gentle with it you should get it off easy enough. its only held in by clips, once the trims off its pretty self explanitory how to get the switch out.
    Matt
    #11
  13. Sm3g
    Offline

    Sm3g STANDARD S3 (225bhp)

    Joined:
    May 22, 2009
    Messages:
    64
    Likes Received:
    1
    [Oct 15, 2009]
    thanks matt,i know exactly what you mean now.il be cracking on with it saturday anyway,audi had the part in stock,they said its a common fault (£38 it cost) not too bad considering iv had the car nearly a year now and this is the only part i have had to replace:icon_thumright:.

    CHEERS EVERYONE!!
    #12
  14. s3 Hoggy
    Offline

    s3 Hoggy Whats going on???

    Joined:
    Apr 4, 2009
    Messages:
    1,659
    Likes Received:
    99
    [Oct 15, 2009]
    Sound mate good luck
    #13

Share This Page