1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

possibly need new engine mounts.

Discussion in 'A3/S3 Forum (8L Chassis)' started by Jonesy, Jun 6, 2007.

  1. Jonesy

    Jonesy Member

    Joined:
    Jun 27, 2004
    Messages:
    570
    Likes Received:
    1
    Hi, whilst driving I get a weird vibration or sort of rubbing feeling, its worst when im braking and pulling off and im guessing the engine mounts are the cause. It also gets really bad at speeds over 80mph, not that I drive that speed everywhere but still doesnt sound healthy.

    ItÂ’s on 80k and the mounts have never been changed, the cars been remapped. Is it best to go for the standard replacements or some uprated ones, how much am I looking at here? Also can I fit them myself as I did my dogbone mount on my Clio Sport without much difficulty.

    Thanks dudes
     
  2. Jonesy

    Jonesy Member

    Joined:
    Jun 27, 2004
    Messages:
    570
    Likes Received:
    1
    are powerflex any good, heard they can possibly cause more rattles due to the extra stiffness?
     
  3. james0808

    james0808 Active Member

    Joined:
    Mar 27, 2006
    Messages:
    3,548
    Likes Received:
    3
    I had a powerflex mount on my golf for a week and it was horrible.Put a standard one back on.
     
  4. Jonesy

    Jonesy Member

    Joined:
    Jun 27, 2004
    Messages:
    570
    Likes Received:
    1
    ya, guess ill be going standard then.
     

Share This Page