1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Possible MAF Problems

Discussion in 'Diesel forum' started by TGM, Nov 19, 2010.

  1. TGM
    Offline

    TGM New Member

    Joined:
    Nov 19, 2010
    Messages:
    4
    Likes Received:
    0
    [Nov 19, 2010]
    Hi All

    I am having issues with my A4 2.0 TDI 170.

    The car feels under powered and not overly prompt on starting. Low revs are a real struggle. It is an 07 plate and has just hit 86K.

    On a reasonably fast motorway run for 2 hours I am hitting around 34 mpg (a little low)

    On occasion the idle is erratic too.

    I have been asking around and a few people suggested that my injectors may be blocked. After several months now of various diesel injector cleaners I am seeing no results.

    I asked around some more and have read a few forums and the diagnosis maybe the MAF.

    Before I spend money to change this, does anyone have any suggestions for cleaning them or is it not worth it?

    Are there any other things i should be looking out for?

    Thanks :zen:
    #1
  2. Ads

    Ads

    [Sep 23, 2014]

  3. navnayyar
    Offline

    navnayyar Member

    Joined:
    Mar 23, 2008
    Messages:
    786
    Likes Received:
    0
    [Nov 19, 2010]
    Simple test to check if it is the maf. Unplug maf, go for a quick drive. Is power the same? If yes maf is knackered. If power is reduced maf is ok. You cam clean it with some brake fluid cleaner spray thingy
    #2
  4. TGM
    Offline

    TGM New Member

    Joined:
    Nov 19, 2010
    Messages:
    4
    Likes Received:
    0
    [Nov 21, 2010]
    Thanks navnayvar.

    Intrestingly last night the oil light came on. About one month ago the oil was fine. Now it is on minimum.

    Could this be all related?
    #3
  5. TGM
    Offline

    TGM New Member

    Joined:
    Nov 19, 2010
    Messages:
    4
    Likes Received:
    0
    [Nov 28, 2010]
    Hi All

    Changed the MAF and still no change.

    The MPG is still 32 on the motorway and still under-powered.

    Linked the ECU to a fault reader but no codes displaying and parameters are coming out normal. However it took several attempts to access the ECU as it kept booting the computer out.

    Any Ideas anybody?
    #4
  6. TGM
    Offline

    TGM New Member

    Joined:
    Nov 19, 2010
    Messages:
    4
    Likes Received:
    0
    [Dec 29, 2010]
    Further update:

    Loaded the car on a rolling road. The Car is a BRD 170 bph 2.0 TDI but I was gettting 100 bph out the wheels and around 130 bph out the flywheel.

    Performed a full engine flush and oil change as I had heard rumours that Audi garages are reknown for not putting the correct oil in these engines.

    anyway, the next day I was driving and the brakes went rock hard and didnt perform and the engine cut out at 80mph on the motorway.

    I think the added load of the rolling road plus the full engine flush may have caused my tandem pump to pack up. Interestingly no oil is in the fuel line yet.....
    #5

Share This Page