1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Possible Ignition Coil problem?

Discussion in 'A3/S3/Sportback (8P Chassis)' started by adamccc, Feb 12, 2013.

  1. adamccc
    Offline

    adamccc Member

    Joined:
    Feb 12, 2013
    Messages:
    63
    Likes Received:
    16
    [Feb 12, 2013]
    Hi Guys newbie here,

    Brought a 07 S3 at the weekend, previous owner remapped it to stage 2+ along with adding Forge PCV catch tank system with relocated Forge washer fluid filler. ITG maxogen intake. Milltek 3" 200 cell down pipe with a reducer into standard cat-back. Autotech fuel pump internals. Cold air feed etc.

    Been driving great until I took it for a drive last night, at around 3-4 thousand revs where the real power kicks in, it misfires and the orange
    emission control light starts flashing. It goes off after about 5-10 seconds of driving around at town speeds - Seems to also idle just below 1k revs, from other videos and posts I think it'd the coilpacks that need replacing.

    Rang Audi and they said my wasnt part of the recall and want £235 for replacing them, Just wanted to get your opinions before taking the plunge
    #1
  2. OVRA3
    Offline

    OVRA3 Well-Known Member

    Joined:
    Jan 19, 2012
    Messages:
    1,079
    Likes Received:
    79
    [Feb 12, 2013]
    Go with plugs first just did mine recently as thats what mine was doing and its sorted it right out, if not coil packs cheap fix first! I would put money on it being the plugs...
    #2
  3. adamccc
    Offline

    adamccc Member

    Joined:
    Feb 12, 2013
    Messages:
    63
    Likes Received:
    16
    [Feb 12, 2013]
    Thanks James, Will try replacing the plugs tonight and then the coil packs tomorrow if the problem persists
    #3
  4. OVRA3
    Offline

    OVRA3 Well-Known Member

    Joined:
    Jan 19, 2012
    Messages:
    1,079
    Likes Received:
    79
    [Feb 12, 2013]
    Mine was missing badly under heavy load at about 3k and it came on all of a sudden so I think you'll be fine with new plugs, Eurocarparts were doing a deal 20% off not sure if its still on? might be worth a look though
    #4
  5. adamccc
    Offline

    adamccc Member

    Joined:
    Feb 12, 2013
    Messages:
    63
    Likes Received:
    16
    [Feb 12, 2013]
    Yeah, I got a set of 4 from Euro car - didn't see anything about the 20% off though - any idea where I can pick up a 16mm spark plug socket from - nowhere seems to be stocking them.
    #5
  6. OVRA3
    Offline

    OVRA3 Well-Known Member

    Joined:
    Jan 19, 2012
    Messages:
    1,079
    Likes Received:
    79
    [Feb 12, 2013]
    Hate to say but Halfords?
    #6
  7. adamccc
    Offline

    adamccc Member

    Joined:
    Feb 12, 2013
    Messages:
    63
    Likes Received:
    16
    [Feb 12, 2013]
    They only go up to 14mm unfortunately, euro car parts didn't have one either - surprisingly just found one at B&Q!
    #7
  8. adamccc
    Offline

    adamccc Member

    Joined:
    Feb 12, 2013
    Messages:
    63
    Likes Received:
    16
    [Feb 12, 2013]
    Right! Plugs are replaced, and hasn't made a difference - the emission control light and 'EMC' light stay on when I insert the key and turn off as soon as I start the car. When accelerating it's fine right until the power from the 2+ remap and intake should come into play (4k revs) and instead I get low-toned pur, no extra power out and the Emission Control light flashes for roughly 7 seconds then turns off.

    Really at a low point with this, only had the car for 2 days and don't really want to waste money replacing the coilpacks if it's not the problem - Any advice on what to do would be great :)
    #8
  9. OVRA3
    Offline

    OVRA3 Well-Known Member

    Joined:
    Jan 19, 2012
    Messages:
    1,079
    Likes Received:
    79
    [Feb 13, 2013]
    Next thing to do is get it scanned and see what comes up. Lots of people with vcds on here. Sure someone will help you on here or take it to an independent; garage mine will scan for 15 quid
    #9
  10. adamccc
    Offline

    adamccc Member

    Joined:
    Feb 12, 2013
    Messages:
    63
    Likes Received:
    16
    [Feb 19, 2013]
    UPDATE: After taking the car to a local garage in London who deleted the error codes, put it on the rolling road and tested it for half a day; They told me nothing was wrong and the 'cars computer was probably just replicating the error and the spark plugs fixed it' - obviously a load of ****. Took it to a friends garage in my home town, charged me £5 to plug in and tell me it was cylinder 4 - grabbed a ignition coil and it's not running like a dream - Thanks for the help!
    #10
  11. OVRA3
    Offline

    OVRA3 Well-Known Member

    Joined:
    Jan 19, 2012
    Messages:
    1,079
    Likes Received:
    79
    [Feb 19, 2013]
    You mean it is running ok now? Good news if it is :) when you have time and spare cash might be worth changing the others they have a tendency to go once one goes.
    #11
  12. adamccc
    Offline

    adamccc Member

    Joined:
    Feb 12, 2013
    Messages:
    63
    Likes Received:
    16
    [Feb 19, 2013]
    Yeah haha, running great now - I can see that the previous owner has already replaced number 3 so only two to go, will do them next month
    #12
  13. OVRA3
    Offline

    OVRA3 Well-Known Member

    Joined:
    Jan 19, 2012
    Messages:
    1,079
    Likes Received:
    79
    [Feb 19, 2013]
    Nice to hear all is well. It's rank when you buy a car and get that sinking feeling. Can't beat a cheap fix!
    #13

Share This Page