1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Popping sound when taking foot off accelerator

Discussion in 'A3/S3/Sportback (8P Chassis)' started by NCRAW, Feb 16, 2012.

  1. NCRAW
    Offline

    NCRAW Member

    Joined:
    Jun 7, 2011
    Messages:
    230
    Likes Received:
    0
    Hi All,

    A question to people with modded exhaust/intake. I have been noticing this popping sound that I thought was coming from the back when im in the traffic light and rev the car to 2000-2500rpm then take my foot off the accelerator quickly (neutral or in first and moving the car slowly fwd). I got to work and asked me colleague to listen to it and it actually sounded like coming from the engine. Further investigation and it seems like coming from under the car, I'm thinking from the dump pipe (turbo back pipe). It doesnt happen if I change to second or take foot off the accelerator slowly or revving it high. I have a Miltek TBE and Forge Twintake plus APR Stage 2. Is this normal or is there some sort of a leak? I always had the crackle and slight pop coming from the back.
    #1
  2. warren_S5
    Offline

    warren_S5 Moderator Staff Member Moderator

    Joined:
    Oct 31, 2007
    Messages:
    7,176
    Likes Received:
    11
    The only time I had anything similar to this it was when my plugs were on the way out and about 100 miles later I started to get big misfiring issues. It was using NGK BKR8EIX plugs which I felt didn't suit the car (Revo 2+).
    #2
  3. NCRAW
    Offline

    NCRAW Member

    Joined:
    Jun 7, 2011
    Messages:
    230
    Likes Received:
    0
    I've put new plugs less than 5k ago. This issue started about a month or so ago. I'm wondering if it is related to my slight rough idling especially when car is not fully warm. I had a better listen and it sounds like coming from under the engine. Or could be the cat. It happens at 1000 to 1100 rpm.
    #3
  4. NCRAW
    Offline

    NCRAW Member

    Joined:
    Jun 7, 2011
    Messages:
    230
    Likes Received:
    0
    Cr*p. wrote a long reply and all gone!! basically issue sorted with the 1100 RPM popping by swapping back to Rev G from Rev D. I went with Rev D thinking that it will match Stage 2 APR better and might sort out the idling issue but it did not plus i got the misfire. I think Rev G has a softer open/close action. Im sticking with it until i sort out this erratic Idling. Was running all beautiful with Stage 2 and Forge Twintake (plus miltek) till the PCV valve went and replaced it with the BSH fix. Since then idling is not fantastic. I replaced the spark plugs with another oem set but not much joy. There are no issues what so ever under throttle but im thinking to try a different set of spark plugs. Maybe NGK BKR7EIX or 8EIX. Failing that then maybe coil packs. I also ordered a new upgraded HPFP which comes with a cam follower and will install that too soon.
    #4

Share This Page