1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Poor MPG

Discussion in 'A4/S4 forum(B5 Chassis)' started by voteforpedro, Mar 14, 2010.

  1. voteforpedro
    Offline

    voteforpedro Member

    Joined:
    Jul 15, 2008
    Messages:
    632
    Likes Received:
    0
    Thermostat and exhaust both sorted but the car is running like pooh. Below 3k revs it drives like my OH's Polo. :( Also I only managed to get 24 mpg on the motorway.

    What are the possible causes of this? I'm too lazy to search because it's my birthday today and I went out last night and I'm very hungover and can't search in my retarded state of mind.

    And because it's my birthday you can provide me with answers, as a present. :)
    #1
  2. griswold
    Offline

    griswold Member

    Joined:
    Jan 25, 2008
    Messages:
    341
    Likes Received:
    5
    Turbo comes in about 3000 revs whats it like after that?
    vag com scan it
    #2
  3. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,495
    Likes Received:
    299
    MAF sensor?
    #3
  4. Broken Byzan
    Online

    Broken Byzan Photographic Moderator Staff Member Moderator

    Joined:
    Apr 26, 2004
    Messages:
    12,568
    Likes Received:
    267
    I would answer but i am too lazy to bother......LMAO

    Could be loads of things from the temp sender, to the MAF to sticky brakes etc
    #4
  5. Broken Byzan
    Online

    Broken Byzan Photographic Moderator Staff Member Moderator

    Joined:
    Apr 26, 2004
    Messages:
    12,568
    Likes Received:
    267
    I would answer but i am too lazy to bother......LMAO

    Could be loads of things from the temp sender, to the MAF to sticky brakes etc
    #5
  6. voteforpedro
    Offline

    voteforpedro Member

    Joined:
    Jul 15, 2008
    Messages:
    632
    Likes Received:
    0
    Checked the inlet hose on the airbox and it was a little misaligned so may have been leaking air slightly. Managed to maintain 24 mpg through Brum today and felt a little more responsive but turbo lagging like fook. :(
    #6
  7. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,495
    Likes Received:
    299
    is the turbo lagging, or just not there at all?

    could be a blocked cat, or perhaps a broken wastegate?
    #7
  8. voteforpedro
    Offline

    voteforpedro Member

    Joined:
    Jul 15, 2008
    Messages:
    632
    Likes Received:
    0
    I don't know what's going on. I can hear it spool sometimes, but other times I put my foot down in first and it'll "stutter" slightly as it hits ~3k revs. I am thinking the wastegate is sticking too.
    #8

Share This Page