1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please help with speedo cluster (DIS)..thanks

amit91987 Feb 18, 2013

  1. amit91987

    amit91987 Member VCDS Map User

    119
    6
    18
    Hello,

    I switched on the car this morning and this came up (please see picture attached). Would anyone know what is wrong?

    Previously I have had the error below:
    Address 17: Instruments Labels: 8P0-920-xxx-17-MY7.lbl
    Part No SW: 8P0 920 981 BX HW: 8P0 920 981 BX
    Component: KOMBIINSTR. VDO H80 0460
    Revision: D08 Serial number: 2258GD08000039
    Coding: 0000443
    Shop #: WSC 12435 123 12345
    VCID: 8F294C689E46CD1


    1 Fault Found:
    16346 - Control Module - ROM Error
    014 - Defective
    Freeze Frame:
    Fault Status: 00000011
    Fault Priority: 1
    Fault Frequency: 1
    Mileage: 107136 km
    Time Indication: 0
    Date: 2012.07.01
    Time: 11:50:59

    I am thinking it could be linked to this, but my DIS was working during this time (not fully, but
    intermittently).

    Speedo cluster problem.jpg

    Please could anyone advise me on this problem.

    Thanks


     
  2. SAiLO

    SAiLO Well-Known Member VCDS Map User

    1,058
    55
    48
    If your DIS was working intermittently then it might have been on its last legs. Looks like the ROM memory in the control module is faulty.
     
  3. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    29,272
    1,685
    113
    Disconnect battery for 10 minutes & reconnect.
     
  4. amit91987

    amit91987 Member VCDS Map User

    119
    6
    18
    Thanks guys, i will give this a go. Much appreciated.
     
  5. amit91987

    amit91987 Member VCDS Map User

    119
    6
    18
    Disconnected the battery, and it lights up now. However, i still am getting a blank screen with no information in it.

    Also have steering wheel and esp light on. I think these will go off later once i drive the car next? ImageUploadedByTapatalk 21361402134.523105.jpg
     
  6. ElliottB

    ElliottB Audi A3

    198
    4
    18
    Hi mate.

    The light with the picture of a steering wheel and the esp light is a 'steering angle sensor' fault. I bought my a3 and a few months after this issue occured. Audi fixed it for me free under the warranty but its about £200 to get sorted by a decent garage.

    Having it plugged in by someone will trll you its that fault straight away
     
  7. amit91987

    amit91987 Member VCDS Map User

    119
    6
    18
    Hello, both lights have now cleared after my drive to work.

    Thanks for your help guys. I still think I need a new DIS as I do have a ROM error. I might have to go for the white dis cluster.

     
  8. mmalh0151

    mmalh0151 Member

    170
    5
    18
    On a separate note, are these meant to have a black line running through the top 1/4 of the DIS display?
     
  9. bmh.01

    bmh.01 Member

    291
    17
    18
    Yes
     
  10. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    29,272
    1,685
    113
    Give me a shout as I can organise the whole lot from start to finish.
     
  11. amit91987

    amit91987 Member VCDS Map User

    119
    6
    18
    PM'd you mate
     
  12. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    29,272
    1,685
    113
    & replied.
     

Share This Page