1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please Help (Possible electrical fault) A4 :(

Discussion in 'A4/S4 forum(B5 Chassis)' started by a4TDI, Sep 5, 2006.

  1. a4TDI
    Offline

    a4TDI New Member

    Joined:
    Mar 27, 2004
    Messages:
    5
    Likes Received:
    0
    [Sep 5, 2006]
    Hey guys

    I have an Audi 1.9tdi (R Reg 1998).

    Basically I switch the engine on (everything starts up fine) then when I use the left or right indicators they don’t work, and when I do the window wipers they do not work either. (They are both linked somehow)

    I then switch the engine back on then they start working again, and then stop again. Basically they start and stop throughout the engine being on.

    I have checked all the fuses in the fuse panel located on the inside driver panel.

    It seems to me I haven’t checked all the other fuses or there is some kind of wire loose?

    Any help or advice would be much appreciated.

    Indy
    #1
  2. Ads

    Ads

    [Oct 25, 2014]

  3. S4_dan
    Offline

    S4_dan Fire up the Quattro!

    Joined:
    Jan 5, 2006
    Messages:
    1,754
    Likes Received:
    79
    [Sep 5, 2006]
    i would probably rule out fuses as sometimes they work and sometimes they dont indicate a power supply is occassionally there.

    I would look at more of a loose connection from the stalks, or an earthing problem possibly linked to the ignition switch?

    check all the wiring looms from the steering column.

    Just my 2p.

    Dan
    #2
  4. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,672
    Likes Received:
    296
    [Sep 5, 2006]
    Ignition switch mate, common fault sadly
    #3
  5. a4TDI
    Offline

    a4TDI New Member

    Joined:
    Mar 27, 2004
    Messages:
    5
    Likes Received:
    0
    [Sep 5, 2006]

    roughly how much am i talking about mate? and would it be easy to fit my self?

    im sick of my audi, had loads of problems :(
    #4
  6. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,672
    Likes Received:
    296
    [Sep 5, 2006]
    IIRC its around £20 thereis a how to somewhere.... might be on Audiworld.com
    #5
  7. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    31
    [Sep 5, 2006]
    Yes it's really easy, 30 minute job. Go to:
    http://www.audiworld.com/tech/elec.html
    then page down twice and select Ignition switch replacement.
    I've got a PDF of the article but you can't link straight to it for some reason.
    The part no. you need is 4A0-905-849-B and my local dealer had one on the shelf as it's a common problem.
    #6
  8. Rev-head
    Offline

    Rev-head Active Member

    Joined:
    Oct 14, 2004
    Messages:
    2,987
    Likes Received:
    7
    [Sep 5, 2006]
    #7
  9. mwarrey
    Offline

    mwarrey Member

    Joined:
    Dec 27, 2003
    Messages:
    280
    Likes Received:
    0
    [Sep 5, 2006]
    I'd say ignition switch as well (same thing happened to me). It is quite straight forward, but make sure you get the correct switch as there are different ones for the A4 (as I found out).

    Also if you are driving the car around before you get it fixed make sure that the starter motor doesn't stay engaged after you start the car. This happened to me and I ended up having to change the starter motor as well which costs over £100 and is a pig of a job.
    #8

Share This Page