1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please explain the fuel system on a 2.5tdi

Discussion in 'A6/S6/Allroad forum (C5 Chassis)' started by samiam, Dec 2, 2009.

  1. samiam
    Offline

    samiam New Member

    Joined:
    Dec 15, 2008
    Messages:
    17
    Likes Received:
    0
    [Dec 2, 2009]
    OK. My car won't start.
    Scanned it.... nothing relevant at all.
    Cranking scanned it. Lots of data. Dunno what's relevant or not.
    I sent the data off to an indie. He said check the fuel pump in the tank.
    OK so I took the rubber hose off and turned the key.... no fuel.
    So I took the cover plate of and jumped the pump with a spare battery... no fuel.
    So I took the pump out and found the intake screen VERY clogged with black sh it. Cool, So I cleaned it out and got the pump squirting fuel very nicely on the bench out of an ice cream container. (what is that black stuff by the way?)
    So I put it all back in and jump the pump... No fuel! ...Well there is fuel getting pumped, but not out the fitting on top of the tank, It's coming out somewhere inside the tank, I can hear and see it swirling around.
    I connect the wiring up again and turn the key... no fuel, no pump, nothing.
    My questions...
    The pump works when jumped, but not with the key. Why not? Relay? If so, where is it and is there another suitable relay I can swap out to test?
    The hose that comes out of the pump dives back down under the diesel to a What??? and then comes back up to the top-of-tank-fitting. What is that thing? It has two fine black wires going to it. Is it a supply solenoid of some sort? Does it have a pressure relief bypass of some sort?(which would then explain the swirling in the tank)
    I have managed to remove the pump, but can't work out how to remove the whole assembly.
    Is it feasible that a pipe/hose is split?
    When I hear/see the swirling in the tank I also see bubbles. But the pump intake is fully submerged. Where the heck is that air coming from.
    Lots of questions... lots of answers please....
    #1
  2. Ads

    Ads

    [Sep 23, 2014]

  3. adamss24
    Offline

    adamss24 Well-Known Member

    Joined:
    Jul 3, 2007
    Messages:
    3,361
    Likes Received:
    175
    [Dec 2, 2009]
    Give us more details about your car ! First, is that a quattro, what year and model, also engine code. How did it stop ? If you have a fuel pump in tank and its a quattro pre 2000 then, chances are that the pump in tank is only priming the main chaimber so the Injector Pump can suck the fuel. If its a quattro after 2000 then you might have a lift pump wich also sends fuel to the injector pump to help it work less. I do not know what faults you get from the engine ECU but i will get the car towed for a few min. while in gear. Its the best way to expell air from system. If it does not start, either the pump is dead-but should trigger a code-timing jumped or the pump is not timed properly. Can you get the car started on brake cleaner spray ? Pull the hose from the MAF and squirt a jet of brake fluid-be carefull as the engine can race to the rev limiter if you spray too much. Check the pump belt for condition, if everything is ok and the car starts on ether, then i suspect fueling problem: either dead pump(Common fault) or air ingress.
    #2
  4. Cockney Boy
    Offline

    Cockney Boy Member VCDS Map User

    Joined:
    Nov 26, 2007
    Messages:
    481
    Likes Received:
    6
    [Dec 2, 2009]
    The black S**t as you call it, is dirty fuel and contaminants.

    The reason why your engine is not getting any fuel because the circuit needs priming (no air in the circuit)
    #3
  5. samiam
    Offline

    samiam New Member

    Joined:
    Dec 15, 2008
    Messages:
    17
    Likes Received:
    0
    [Dec 2, 2009]
    Thanks for the replies.
    It's a 2000 Allroad. Auto, so no tow starting sorry. I wish it was a manual!
    The pump is definitely not stuffed... it sent a nice big fountain of diesel into the air when set up on the bench.
    As I said before, in the car the pipe comes out of the pump and then dives back down to another unit that is submerged in diesel. This unit has two fine black wires going to it, finer than standard auto wire. What is this unit? But the issue seems to be that when I wire everything up and turn the key the pump doesn't go. When I jump it, it does, however that doesn't jump the mystery unit. Because it has fine wires going to it I'm not prepared to jump it without further guidance.
    Once I can get fuel squirting out the correct pipe... then I can prime the system again.
    #4
  6. samiam
    Offline

    samiam New Member

    Joined:
    Dec 15, 2008
    Messages:
    17
    Likes Received:
    0
    [Jan 11, 2010]
    adamss, I think you are onto something here. I had to trailer the car to a indie and they have got it going. Now i haven't been and got it yet, but he explained, over the phone, that the issue is a priming one. He suggested the pump is of the earlier type and that the VP44 injection pump couldn't suck up sufficient fuel to start. Once going it goes fine. Injector pump getting tired? Supply pump no good?
    Now this begs the questions ....
    The early type pump , I'm assuming just primes the system and then turns off, leaving the injection pump to do the rest?
    The Later type keeps feeding pressure all the time?
    Can I fit a later type pump (and what else?) to do the job properly, I'm assuming that's why Audi (VW?) made the change. If so, which VAG vehicles have the right pump in them.
    #5
  7. etronic
    Offline

    etronic TDI VCDS Map User

    Joined:
    Dec 13, 2007
    Messages:
    69
    Likes Received:
    0
    [Jan 12, 2010]
    Listen mate... VP44 are VERY delicate. If you crank it without fuel in the circuit you'll kill the pump. It's got to be primed in the way that there should be no VP activity until it's got fuel in it otherwise it gets f*^%&ed pretty quick. Towing is also forbidden as engine is equipped in CAT.

    Just check tank pump properly. Maybe you have one of the hoses/pipes cracked. Too many variables to give the exact solution/advice....
    #6
  8. samiam
    Offline

    samiam New Member

    Joined:
    Dec 15, 2008
    Messages:
    17
    Likes Received:
    0
    [Jan 15, 2010]
    Thanks for the replies. I picked up the car today and according to the (accredited VW) indie who fixed it... The VP44 pump is the issue. I now understand that within the VP44 is a nother feed pump which sucks the fuel in and boosts the pressure up for the high pressure pump to send off to the nozzles.
    It's this primary pump which is worn, due to 170,000km's and a small amount of diesel bug.
    The car is running fine now... but for how long?
    A friend has a Passat 2.5tdi which hydrauliced it's motor and insurance put a complete new motor in, out of an allroad as luck would have it! So he has a working VP44 sitting in a box (it never got wet). My thoughts are to buy it off him, get it checked out/calibrated and swap pumps.
    Questions...
    Are they compatible?
    which numbers do I need off the units (and where are they) to ascertain compatibility.
    If not, would swapping the EDC off the top make them compatible?
    Any other thoughts?
    What do any of you do about diesel bug?
    #7
  9. wabtheking
    Offline

    wabtheking New Member

    Joined:
    Nov 22, 2006
    Messages:
    6
    Likes Received:
    0
    [Jan 16, 2010]
    so should the pump in the tank push fuel out of the pipe in the top of the tank to prime the system?

    im having the same problem, filled up the fuel filter with diesel and tried to crank over, got diesel comoing out of the injector pipes

    spent 2 days on this now with still no fuel coming out of the tank - even with a new pump fitted
    #8
  10. samiam
    Offline

    samiam New Member

    Joined:
    Dec 15, 2008
    Messages:
    17
    Likes Received:
    0
    [Jan 16, 2010]
    Ok I have the numbers for the two injection pumps now...
    My pump Audi 0470506016, Bosch 059130106E
    His pump VW 0470506010, Bosch 059130106C
    What differences?
    Is it just the Electronic Diesel Controller, which is an easy swap?
    My car wouldn't start this morning again...Oh joy!
    #9
  11. etronic
    Offline

    etronic TDI VCDS Map User

    Joined:
    Dec 13, 2007
    Messages:
    69
    Likes Received:
    0
    [Jan 17, 2010]
    Yours is for AKE 180BHP engine and the other one is for AKN 150BHP engine. They won't match.
    @samiam

    Why don't you get your pump to Bosch service for checkup? They (if professional and well equipped) will be able to tell you if your pump is good or not.

    Personally i think that pump is on it's way out. most probably got damaged by extensive cranking while not primed.

    Regarding diesel bug, there is no issue with it in this country if you use diesel from petrol stations. Quality of fuel in here is good.

    @wabtheking

    Is the diesel form injectors pipes coming out very pressurized or it's just the leak?

    Does you tank pump working at all when you turn ignition on?
    #10
  12. wabtheking
    Offline

    wabtheking New Member

    Joined:
    Nov 22, 2006
    Messages:
    6
    Likes Received:
    0
    [Jan 17, 2010]
    yes the pump primes when cranking,

    the diesel coming out of the injector pipe isnt enormous high pressure, having said that all i had done was fill up a funnel of diesel piped into the filter just before the injector pump to check it was sucking diesel in - it is, should the injector pump create enough suction to drag fuel out of the tank?
    #11
  13. wabtheking
    Offline

    wabtheking New Member

    Joined:
    Nov 22, 2006
    Messages:
    6
    Likes Received:
    0
    [Jan 18, 2010]
    vp44 pump is not pressurising enough, its mearly pi55ing out rather than being pressured out, anyone got a good 2nd hand one?
    cheers
    will
    07976299409
    #12
  14. Neutech
    Offline

    Neutech New Member

    Joined:
    Jul 8, 2006
    Messages:
    19
    Likes Received:
    0
    [Feb 3, 2010]
    all this sounds like the same issues i've been having for months with 2 AFB 2.5TDi engines 1 in A6 1 in A4 the A6 has now gone .... good luck to the new owner

    The A4 has had the VP44 refurbed by Bosch repair centre

    tank pump all checked, system primed and checked for leak/pressure in all pipes but it wont go at all, im thinking coding issue with VP44 ?

    Anyone shed light on this?

    @ wabtheking - local Audi breaker to me has a few pumps for VP44 drop me a PM with all the details off the pump and i'll see if he has one to match

    Thanks
    #13
  15. Khi
    Offline

    Khi New Member

    Joined:
    Jun 20, 2010
    Messages:
    6
    Likes Received:
    0
    [Jul 22, 2010]
    Your A6 you sold wasn't a grey Audi A6 2.5TDi 2000reg (with A3 wheels) sold to a woman in North Wales was it? The one we bought off her a month or so ago has the same issues, and I think she bought it around the beginning of the year!

    If it is I'd be really interested to know things you've tried and symptoms you were suffering!
    Last edited: Jul 22, 2010
    #14

Share This Page