1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Play in top mounts?????

Tom Mineral Grey S3 Mar 28, 2009

  1. Hey,

    Had my S3 serviced recently and was told the suspension top mounts have a small amount of play. When im driving it it feels 'loose' and wondered if anyone can help in shedding some light on how to fix this?
    I was thinking possibly replace the bushes but dont know if this will help?

    Any info would be great!

    Cheers

    Tom
    :blackrs4:
     
  2. S3APY

    S3APY Member

    127
    0
    16
    I think KW have a better mount. I have traid some diffrent things but its not easy man. Its not a good patent on a fast for shure...:superman:
     
  3. cheers buddy, ill have a look for them.
    does anyone know if this a common issue with the S3?
     
  4. nick-barnes07

    nick-barnes07 Member

    552
    0
    16
    top mounts are common, about £15 each or less from audi, and is a sraight forward job, replace the bearing's whilst you change the top mounts as well as they are only cheap
     
  5. bantam1

    bantam1 Member

    529
    2
    18
    Just had mine done and made a lot of difference to how the car rides.

    Didn't quite follow S3APY's response to this. Translation please.
     
  6. S3APY

    S3APY Member

    127
    0
    16
    Sorry man. I think my english and the topmounts is about 50/50... :)8<
     
  7. bantam1

    bantam1 Member

    529
    2
    18
    OK i give up.
     
  8. Cheers lads thats a gret help:thumbsup:
     
  9. S3APY

    S3APY Member

    127
    0
    16
    My car was loose with org bushing... Go for some PowerFlex and i think you will be one happy little lady...:yahoo:
     

Share This Page