1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Passenger side brake light problem

Discussion in 'A3/S3 Forum (8L Chassis)' started by richardshoes, Feb 25, 2013.

  1. richardshoes
    Offline

    richardshoes New Member

    Joined:
    Jul 25, 2011
    Messages:
    11
    Likes Received:
    0
    Hi,
    My passenger side brake light stopped working on my S3 2002. I changed the bulb, but that did not solve the problem.
    Can someone offer any advice as to what might be causing this? is this a common issue?
    Thanks,
    #1
  2. Lemon S3
    Offline

    Lemon S3 Alex

    Joined:
    Sep 1, 2009
    Messages:
    1,316
    Likes Received:
    9
    I have the same problem, it's an intermittent fault, I'm guessing a bad connection somewhere.
    #2
  3. S3 Paul
    Offline

    S3 Paul Active Member Staff Member Regional Rep

    Joined:
    Oct 27, 2006
    Messages:
    2,784
    Likes Received:
    75
    i had this on my 01 S3
    first i thought dodgy connection on the bulb... turned out to be the brake switch on the pedal,
    worth a look as they arent expensive
    #3
  4. Squirrelofdoom
    Offline

    Squirrelofdoom Member

    Joined:
    Feb 2, 2012
    Messages:
    543
    Likes Received:
    15
    yeah. If you can, scan it to see if a brake light switch fault comes up. Otherwise I would say just swap the brake light switch because it's so cheap. 5 minute job mate, really easy. Had to do mine recently because ALL of my brake lights stopped working (lol) :)
    #4
  5. Lemon S3
    Offline

    Lemon S3 Alex

    Joined:
    Sep 1, 2009
    Messages:
    1,316
    Likes Received:
    9
    Miss read your original post, glanced over 'brake'. Mine's the light rather than the brake light.
    #5
  6. richardshoes
    Offline

    richardshoes New Member

    Joined:
    Jul 25, 2011
    Messages:
    11
    Likes Received:
    0
    Thanks for the comments. I'll report back when it's fixed. Cheers
    #6
  7. richardshoes
    Offline

    richardshoes New Member

    Joined:
    Jul 25, 2011
    Messages:
    11
    Likes Received:
    0
    Replaced brake switch and this fixed the problem. Thanks
    #7

Share This Page