1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Over heating!!!

Discussion in 'A6/S6/Allroad forum (C5 Chassis)' started by imported_alex100a, Mar 28, 2005.

  1. imported_alex100a
    Online

    imported_alex100a Guest

    [Mar 28, 2005]
    My 2.8L V6 Quattro keeps overheating and there is no cold air in the car. Just replaced thermostat (after I found the B thing) but to my horror this has not sorted the problem.

    Could it be the water pump has packed up?? don't really want to strip down again to find its something else.

    Thanks
    #1
  2. Ads

    Ads

    [Oct 25, 2014]

  3. a4sline
    Offline

    a4sline Member

    Joined:
    Oct 2, 2004
    Messages:
    185
    Likes Received:
    1
    [Apr 3, 2005]
    Sounds like the old impeller has fallen off the back of the water pump scenario....
    Bite the bullet and change the pump. Should cure
    #2
  4. duxster
    Offline

    duxster New Member

    Joined:
    Jul 28, 2005
    Messages:
    7
    Likes Received:
    0
    [Apr 4, 2005]
    had the same symptons, my pump and thermostat changed £240.
    #3
  5. imported_alex100a
    Online

    imported_alex100a Guest

    [Apr 5, 2005]
    Changed water pump and yep the dam thing had fallen apart!

    Cheers
    #4
  6. a4sline
    Offline

    a4sline Member

    Joined:
    Oct 2, 2004
    Messages:
    185
    Likes Received:
    1
    [Apr 6, 2005]
    Whey Hey, Top Banana
    /ubbthreads/images/graemlins/beerchug.gif
    #5

Share This Page