1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Over boost problems

Discussion in 'A3/S3 Forum (8L Chassis)' started by scotty_24, Oct 12, 2013.

  1. scotty_24
    Offline

    scotty_24 Member

    Joined:
    Feb 11, 2011
    Messages:
    211
    Likes Received:
    0
    I'm at my wits end with this car now.
    Its a Revo stage 1 S3 amk.
    under full throttle the boost is shooting up to 2 bar and then rapidly dropping off to .8 bar.
    I have fitted an oil catch can to eliminate oil in the boost system, as well as fit a front mount intercooler.
    When the n75 is unplugged the car under full throttle hits roughly .4 bar.
    When the Maf is unplugged the over boost still happens.
    Does anyone have any ideas or have has this before?
    Scans with vcds show no faults.
    Exhaust is not smoking at all.

    May be a n75 problem? Or my worst fear is a new turbo?
    #1
  2. scotty_24
    Offline

    scotty_24 Member

    Joined:
    Feb 11, 2011
    Messages:
    211
    Likes Received:
    0
    Bump any one have any ideas?
    #2
  3. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,726
    Likes Received:
    20
    probably not a turbo issue if its hitting 2bar... unplug the N75 electrically and see if there is any difference... sounds like it could be the N75 tbh... seen this before... they 0.8bar thing is limp mode from overboost..

    Scan for fault codes too... check for split pipes etc.. all the usual stuff... if you can find a friend with a 1.8t then try their N75 if you can... 50 quid part else so worth testing to be sure...

    <tuffty/>
    #3
    vivalacoulter likes this.
  4. scotty_24
    Offline

    scotty_24 Member

    Joined:
    Feb 11, 2011
    Messages:
    211
    Likes Received:
    0
    Yeah my money is on the N75, I work next door to TPS so Im going to grab one on my lunch and try it. Even if its not that Im happy to replace it as the cars never had one in its 11 years!

    Im also going to try a standard DV, Im not Convinced with my 007p
    #4
  5. scotty_24
    Offline

    scotty_24 Member

    Joined:
    Feb 11, 2011
    Messages:
    211
    Likes Received:
    0

    Well tonight ive fitted a new N75 and OEM Diverter Valve and all is good!
    Spikes at 1.5 bar and holds 1.2 to red line in every Gear!
    Thanks for the help Tuffty and Bill on this and all the other threads I have posted. You are both 20v T legends!
    #5
    Revo Steve-W likes this.
  6. captainshortlegs
    Offline

    captainshortlegs New Member

    Joined:
    Aug 13, 2013
    Messages:
    25
    Likes Received:
    0
    my revo map used to spike at 1.5 then back off to 1.2 pulled the file out after finding were they hid the seed key and had a look over it didnt really impress me the off boost part of the map was actually detunned and the on boost tunned too far then held back by boost limiter , so its constantly fighting itself . sent file over to jonny at protune who virginised it then retuned it . its must more responsive feels lighter to drive and pulles on smoother but harder than before , wouldnt have another revo map if it was free there not for too much point and go not enuf balenced power delivery
    #6
  7. scotty_24
    Offline

    scotty_24 Member

    Joined:
    Feb 11, 2011
    Messages:
    211
    Likes Received:
    0
    Ok...........
    #7
    Revo Steve-W likes this.

Share This Page