1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Oil Warning Light Shenanigans......:(

evilscotsman May 6, 2009

  1. evilscotsman

    evilscotsman Space Cowboy

    1,350
    14
    38
    Jeesus H Christ, its at it again.

    The oil normally goes down at a litre per 1000 miles, and so when it gets to the min mark I add a litre of synth, and away we go. Till now.....

    I had to add 2 litres the other day after an orange oil warning light (not the red level one) came on and I guess it was pressure. I know now that if you press the CHECK button when an error is beeping, it tells you in text what the problem is....! (never knew that till this morning) so I know the red one is level, cos it started doing that one after topping up and after every mile or so, it beeps constantly about "switch engine off and check oil level" - its still fine, checked it 3 times, but still the warning.

    Anyone had a wire come off the level sensor and know where its at? I guessed near the filter but hoping its that and not a blocked strainer. I googled it but can't find a pic.

    Its not noisy, runs fine etc and has enough oil, just bouncin ideas lads, what do yous think?
     
  2. sebbelcher

    sebbelcher Member

    53
    0
    6
    I feel for you buddy! Those three beeps are the most soul destroying sounds I've ever heard!

    Audi told me the RED oil warning is a pressure warning, not a level warning, it just tells you to check the level as low oil can cause low pressure.

    Did you ever get your pickup filter replaced after the last problem? If not, then I'm afraid it may well be the blocked strainer. My A4 did 600miles after a flush when I had the pressure problem but eventually it clogged up again and the warning came back, I fear the same may have happened to yours, albeit further down the line.

    Cost me £450 to have the sump cleaned and a brand new oil pump. :(
    I am still trying to claim this back off Audi UK under a 'fitness for purpose' type claim because I discovered that American Audi 1.8T owners were given an extended 8 year warranty on all engine oil problems after a class-action law suit was filed.

    Audi UK are currently denying this is a common problem (despite the dealer, the AA and virtually everyone else I speak to saying it's common as muck).

    Good luck.
     
  3. D8UGF

    D8UGF Member

    107
    0
    16
    Sebbelcher,

    Let me know how you get on, im afraid I dont think you will get anywhere with them, the same thing happened to me halfway through a service schedule and I gave them the whole Audi US warranty story, they basically said that what Audi US does is entirely up to them but that in the UK there is no commonn fault with this engine.

    We should maybe point them in the direction of this forum! I ended up paying half the 800 pounds quoted for the repair.

    Good luck.

    Sorry for the Hijack Evil!!
     
  4. evilscotsman

    evilscotsman Space Cowboy

    1,350
    14
    38
    np mate.

    I have found if I drive the car gently, never go over 3k rpm, and cruise at 55 the oil warning doesnt happen so the pump must be sucking the sludge up against the strainer at higher engine speeds. I have an idea, but havent tried it yet.....and its to drain the **** out, then pour petrol into the oil intake - enough that the strainer is submerged in fuel which may dissolve the sludge, then drain that out, and flush thru until the fuel comes out clear....wonder if that will clean the strainer without taking the sump off?

    Obviously not running the engine whilst the fuel is in there but just as a flushing agent / solvent.
     
  5. sebbelcher

    sebbelcher Member

    53
    0
    6
    Definitely worth a shot. I was going to go down a similar route, but in the end I just wanted the peace of mind and got the work done.

    It's just such a pain that you have to lift the engine up to get the sump off, otherwise it would be quite an easy job to clean the thing at home.
     
  6. evilscotsman

    evilscotsman Space Cowboy

    1,350
    14
    38
    yeah it would eh. I am going to try the petrol thing next weekend.
     
  7. evilscotsman

    evilscotsman Space Cowboy

    1,350
    14
    38
    well, I drained the old oil, black it was, but not thick. I refilled it after an hour of draining but was unable to get an oil filter, so the original (which was new 6000 miles ago) had to stay, so not as complete a change as I would have liked but I need the car and can't put off using it.

    Soon as I started the car and drove, the warning came back.....I did run over a big plastic thing on the motorway last week and thats when this started so the sensor is probably buggered. It sits right down on the bottom of the sump and is easy to get at, but anyone know how much they are or had to change theirs?

    The engine seems to run fine with no noises or rattles even at higer revs so i'm assuming it is actually getting oil, or it wouldnt be here now! I've done 300 miles with the flippin light on and beeping away but it still runs ok.

    ???
     

Share This Page