1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Oil Warning 3 Beeps but oil level high

Discussion in 'A3/S3 Forum (8L Chassis)' started by Spatula, Feb 1, 2013.

  1. Spatula
    Offline

    Spatula 1.8T AGU

    Joined:
    Jan 18, 2013
    Messages:
    218
    Likes Received:
    20
    [Feb 1, 2013]
    Hi again,

    So last night I changed t/stat. Engine reaches temp perfectly now. I took it for a drive after and whilst climbing a fairly laborious hill, the oil warning flashed in centre with 3 bleeps.

    It did it about every 4 or 5 minutes from then until I got home (approx 20 mins after). This morning I checked the dip stick and the oil level seems to be above max. I had driven a 10 minute drive to work and since then it's been left 2 hours before I checked. Maybe the oil is still warm and expanded. I will check again at dinner, but I have a feeling the warning wasn't low oil..

    Any ideas?

    Spat
    #1
  2. Ads

    Ads

    [Dec 17, 2014]

  3. jojo
    Online

    jojo Looking for Boost! Staff Member Moderator

    Joined:
    Sep 4, 2003
    Messages:
    26,698
    Likes Received:
    2,008
    [Feb 1, 2013]
    1.8T I presume? The beeps is an oil pressure warning, I'd stop driving it until it's sorted. What's the mileage on the car? May I suggest you replace the oil pick up, it's a common problem.
    #2
  4. Spatula
    Offline

    Spatula 1.8T AGU

    Joined:
    Jan 18, 2013
    Messages:
    218
    Likes Received:
    20
    [Feb 1, 2013]
    Yep it's a 1.8t, agu (1998). Erm, the miles are rather high... 188k.
    How does one go about replacing the oil pick up? Parts / instructions etc?

    Thanks :)
    #3
  5. jojo
    Online

    jojo Looking for Boost! Staff Member Moderator

    Joined:
    Sep 4, 2003
    Messages:
    26,698
    Likes Received:
    2,008
    [Feb 1, 2013]
    #4
  6. Spatula
    Offline

    Spatula 1.8T AGU

    Joined:
    Jan 18, 2013
    Messages:
    218
    Likes Received:
    20
    [Feb 1, 2013]
    Ok so I found a lot of scary things that this issue can cause. I have taken immediate action and called my local Audi. They have ordered me some parts that will arrive tomorrow. (Oil Pickup pipe, Dip stick housing and oil filter) altogether comes to about £24.00 inc vat., which I don't think is too bad.

    I will start tomorrow, removing the sump, cleaning it etc then replacing the Oil pickup. Is there anything I should look out for? I've seen some nice instructions however that was for a 2000 S3. Will mine virtually be the same in this respect?

    Also, what kind of damage will it have done me driving it if the engine is being starved of oil? I hope I havent f'd it :unsure:
    #5
  7. Prawn
    Offline

    Prawn My other car is a MINI!!!!

    Joined:
    Dec 8, 2006
    Messages:
    9,844
    Likes Received:
    1,548
    [Feb 1, 2013]
    s3 will be identical to yours on the sump mate.

    I'd start by dropping the sump and checking the pickup, but it's entirely possible it could be the oil pump that's not pumping enough.

    Hopefully just the pick up, start with that and see what happens.

    how long have you driven it with the oil light on?

    The AGU doesn't have an oil level low sensor, so the warning you see is definitely pressure, which is very serious. If you carried on driving for 20 mins with the low pressure light on there's every chance it could be knackered, so be prepared for the worst, but conversely, I've done the same before on a car I didn't care less about, and after an oil change it ran fine and didn't knock at all.
    #6
  8. Pabl0
    Offline

    Pabl0 Member

    Joined:
    May 2, 2010
    Messages:
    140
    Likes Received:
    6
    [Feb 1, 2013]
    Following the guide, it's pretty obvious mate I'm sure your be fine.

    Hopefully very little to no damage has been done, did It sound okay yesterday after your drive?
    #7
  9. danger S3
    Offline

    danger S3 Member

    Joined:
    Jun 28, 2010
    Messages:
    355
    Likes Received:
    12
    [Feb 1, 2013]
    there's a couple of links in my signature that might help
    #8
  10. Spatula
    Offline

    Spatula 1.8T AGU

    Joined:
    Jan 18, 2013
    Messages:
    218
    Likes Received:
    20
    [Feb 1, 2013]
    The only strange sound was a high pitch clicking coming from the heads? I'm not sure if this is anything to do with it, as I noticed this before the warning light even started beeping, i.e, when I had the bonnet up after I'd finished changing the t/stat. I didn't really think anything of it as I assumed it was normal. However looking at this it sounds this could have been caused by low oil pressure.

    This is my first A3, so please bare with me as I'll probably be asking many stupid questions etc for awhile. :)

    With regards to the clicking, will this be sorted when the flow is clean and oil is circulating correctly, or is this damage that will need serious money throwing at it to repair?

    Spat
    #9
  11. Spatula
    Offline

    Spatula 1.8T AGU

    Joined:
    Jan 18, 2013
    Messages:
    218
    Likes Received:
    20
    [Feb 1, 2013]
    Brilliant, this sump removal was the one I found :salute: great guide!

    @Prawn - I drove maybe 5 miles? it came on then went off about 4 times. About 4 or 5 minute intervals. I nursed it home.
    There doesn't seem to feel like there has been any change. All feels normal. Just the ticking..
    #10
  12. Pabl0
    Offline

    Pabl0 Member

    Joined:
    May 2, 2010
    Messages:
    140
    Likes Received:
    6
    [Feb 1, 2013]
    The 1.8t is a 'clicky/tappy' engine compared to some, so it's hard to rely on that alone for diagnosis.

    A friends oil light flashed up at 80 on the motorway and he's drove like it for an hour, pulled up and it sounded awful. Pick up change and it's back to normal although of course there will be some internal damage.
    #11
  13. Spatula
    Offline

    Spatula 1.8T AGU

    Joined:
    Jan 18, 2013
    Messages:
    218
    Likes Received:
    20
    [Feb 1, 2013]
    It's not that it sounds awful. The ticking can only be heard when bonnet is lifted.
    The car has done a fair few miles though and I have no idea when it was last serviced with oil change etc. So that's this weekends job, obviously, if removing the sump :sly:

    I have read a HUGE thread regarding oil to put in and whether or not to flush the oil, as far as I can make out, the best stuff to go for is named brand 10w/40? and not to flush incase of moving clumps and them just blocking up little hoses etc.?

    I trust this stands true with my situation?

    Spat
    #12
  14. Prawn
    Offline

    Prawn My other car is a MINI!!!!

    Joined:
    Dec 8, 2006
    Messages:
    9,844
    Likes Received:
    1,548
    [Feb 1, 2013]
    ticking from the head is most likely dry tappets due to not getting enough oil.

    Drop sump, change pickup, run it up to temp and see what happens mate.

    Also worth noting this issue will only show up when driving, as the ecu stupidly doesn't show the oil pressure light until over 2k rpm or something like that!
    #13
  15. Spatula
    Offline

    Spatula 1.8T AGU

    Joined:
    Jan 18, 2013
    Messages:
    218
    Likes Received:
    20
    [Feb 1, 2013]
    Ok cool. Well I'll start removing the sump and things tonight, Audi say the parts will be in tomorrow morning so I'll go down there and get the parts. Oh, what's the stuff I use to seal the sump up with? Does it have to be a particular one?
    #14
  16. danger S3
    Offline

    danger S3 Member

    Joined:
    Jun 28, 2010
    Messages:
    355
    Likes Received:
    12
    [Feb 1, 2013]
    yeah just use the genuine VAG sump sealant, can't remember the part number but the dealer will have it
    #15
  17. Pabl0
    Offline

    Pabl0 Member

    Joined:
    May 2, 2010
    Messages:
    140
    Likes Received:
    6
    [Feb 1, 2013]
    Use Dirko sealant, elring number 030.790

    I use fuchs 10/40w as its around £20 for 5 liters and is perfect for this engine.
    #16
  18. Spatula
    Offline

    Spatula 1.8T AGU

    Joined:
    Jan 18, 2013
    Messages:
    218
    Likes Received:
    20
    [Feb 1, 2013]
    Ok brilliant I'll order that stuff up from my L/D. Is there any particular good stuff to clean the oil etc. from the sump? I have a feeling it's going to be preeeeeeeetty messy. :blush:
    #17
  19. danger S3
    Offline

    danger S3 Member

    Joined:
    Jun 28, 2010
    Messages:
    355
    Likes Received:
    12
    [Feb 1, 2013]
    #18
  20. Spatula
    Offline

    Spatula 1.8T AGU

    Joined:
    Jan 18, 2013
    Messages:
    218
    Likes Received:
    20
    [Feb 1, 2013]
    :thumbsup: thanks! I'm looking forwards to cleaning that bad boy out... New oil and things should make it run a lot better too, I hope.

    I'll keep you updated as to how I get on.
    #19
  21. ScottyG60
    Offline

    ScottyG60 New Member

    Joined:
    Mar 25, 2013
    Messages:
    12
    Likes Received:
    0
    [Jun 7, 2013]
    BUMP!!

    So how did ya get on with it, clogged or not?

    I've got the beeps of doom on mine and i've just swapped the engine out and had it all to bits and cleaned and it starts beepin intermittant around 2k, the pump seemed ok when sump was off and i could see the lift pipe wasnt clogged, any ideas? also i just replaced the oil pressure switch for genuine
    #20
  22. hades-
    Offline

    hades- Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,063
    Likes Received:
    554
    [Jun 7, 2013]
    pump
    it may look ok but you cant tell by looking.
    #21
    Tim_Attard likes this.
  23. Tim_Attard
    Offline

    Tim_Attard Active Member

    Joined:
    Nov 12, 2012
    Messages:
    466
    Likes Received:
    43
    [Jun 7, 2013]
    id vote pump, mine has gone too especially if its intermittant
    #22
  24. ScottyG60
    Offline

    ScottyG60 New Member

    Joined:
    Mar 25, 2013
    Messages:
    12
    Likes Received:
    0
    [Jun 7, 2013]
    pumpis now my last option or elec issue, just cleaned the **** out of the lift pipe and still same prob
    #23

Share This Page