1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Oil pressure light again 1.8t HELP!!

Discussion in 'A3/S3 Forum (8L Chassis)' started by Ryan360, Jun 22, 2011.

  1. Ryan360
    Offline

    Ryan360 Member

    Joined:
    Sep 12, 2010
    Messages:
    38
    Likes Received:
    0
    [Jun 22, 2011]
    Hi guys, i know theirs probally been a few posts already on this but im wondering if someone can help me abit more.
    Basically ive got a 99 agu 1.8T engine.. the oil pressure light flashes up on the dash and bleeps whenever i go round a corner above about 40mph, ive changed my oil, oil filter, dropped the sump & cleaned, replaced oil pickup pipe and also i have changed my oil pressure switch (today) but still the dreaded oil pressure light comes on.

    Any ideas whats causing this, engine runs fine does not sound too tappy.

    Help appreciated cheers
    #1
  2. Ads

    Ads

    [Sep 19, 2014]

  3. superkarl
    Offline

    superkarl MAN OF STEEL

    Joined:
    Mar 28, 2010
    Messages:
    7,614
    Likes Received:
    1,102
    [Jun 22, 2011]
    If it doesnt change thw sound of the engine then perhaps its a false warning and a sensor is dodgy. If you really did have low pressure your top end would sound like a bag of spanners, like, really loud and clangy
    #2
  4. bazil
    Offline

    bazil BOOM BOOM

    Joined:
    Mar 25, 2010
    Messages:
    135
    Likes Received:
    4
    [Jun 22, 2011]
    oil level light? maybe a faulty oil level indicator?
    #3
  5. Ryan360
    Offline

    Ryan360 Member

    Joined:
    Sep 12, 2010
    Messages:
    38
    Likes Received:
    0
    [Jun 22, 2011]
    Hmmm on a few occasions it has sounded pretty tappy top end after a long drive but will sound fine again the next day when i start it up..?
    Isn't the sensor same as the switch?
    #4
  6. bazil
    Offline

    bazil BOOM BOOM

    Joined:
    Mar 25, 2010
    Messages:
    135
    Likes Received:
    4
    [Jun 22, 2011]
    where was the one you changed?
    #5
  7. Ryan360
    Offline

    Ryan360 Member

    Joined:
    Sep 12, 2010
    Messages:
    38
    Likes Received:
    0
    [Jun 22, 2011]
    on the oil filter housing, at the side.
    #6
  8. bazil
    Offline

    bazil BOOM BOOM

    Joined:
    Mar 25, 2010
    Messages:
    135
    Likes Received:
    4
    [Jun 22, 2011]
    i talking about the one on the sump, oil level not oil pressure, maybe do a test on it to see if its working correctly?
    #7
  9. superkarl
    Offline

    superkarl MAN OF STEEL

    Joined:
    Mar 28, 2010
    Messages:
    7,614
    Likes Received:
    1,102
    [Jun 22, 2011]
    if you have increased tappy sound at top end then the only thing left, and prob the most important one, is the oil pump. which is another sump off jobby
    #8
  10. Lee172
    Offline

    Lee172 GT3071

    Joined:
    Jul 20, 2010
    Messages:
    431
    Likes Received:
    2
    [Jun 22, 2011]
    I agree with superkarl, if you have done all the oil pickup, sensor etc etc. the next thing i would do is oil pump. What oil are you using?
    #9
  11. bazil
    Offline

    bazil BOOM BOOM

    Joined:
    Mar 25, 2010
    Messages:
    135
    Likes Received:
    4
    [Jun 22, 2011]
    so neither of you would eliminate the oil level sensor first? the OP did say the light comes on when cornering, imo id check the level sensor was ok before buying and fitting an oil pump,

    mine sounded a little noisey uptop before doing my pick up pipe and engine flush but has since quietened down,

    just my opinion lads,
    #10
  12. Lee172
    Offline

    Lee172 GT3071

    Joined:
    Jul 20, 2010
    Messages:
    431
    Likes Received:
    2
    [Jun 22, 2011]
    I wouldn't personally say it was the oil level sensor as Ryan has stated its tappy sometimes after a long drive, i could be wrong but i dont think it would sound tappy if the oil level sensor was faulty, it would just say the sump was empty when its not or visa versa. As long as there is enough oil in there it will circulate. Im sure after doing an oil change the oil would be on or near max. So the fact that its tappy means the oil isnt circulating properly.
    Last edited: Jun 22, 2011
    #11
  13. bazil
    Offline

    bazil BOOM BOOM

    Joined:
    Mar 25, 2010
    Messages:
    135
    Likes Received:
    4
    [Jun 22, 2011]
    well im wrong, oops, just checked my owners handbook and the warning for low oil level or oil level sensor failure is a yellow warning not a red one.

    sorry guys. oil pump it is then,
    #12
  14. Ryan360
    Offline

    Ryan360 Member

    Joined:
    Sep 12, 2010
    Messages:
    38
    Likes Received:
    0
    [Jun 22, 2011]
    Hmmm yeh oil pump next i recon :/ I'm using 10w40 Castrol lee.
    Oh ryt, i have looked before on my sump and there isn't a oil lever sensor there, there's a space for one...i presumed they were not on a3's that earlier but could be wrong?

    Worth getting my car pressure tested at a garage before replacing the pump?
    #13
  15. superkarl
    Offline

    superkarl MAN OF STEEL

    Joined:
    Mar 28, 2010
    Messages:
    7,614
    Likes Received:
    1,102
    [Jun 22, 2011]
    its an oil LEVEL sensor, nothing to do with oil pressure. so that rules that out.
    oil pump next
    #14
  16. Lee172
    Offline

    Lee172 GT3071

    Joined:
    Jul 20, 2010
    Messages:
    431
    Likes Received:
    2
    [Jun 22, 2011]
    Does it ever sound tappy when its cold ryan? or always when its hot?

    When it does sound rattly/tappy can you hear exactly where it is coming from? (maybe using a screwdriver to your ear to hear under the rocker cover)

    I have been having the same problem as you recently, changed the sensor, oil pickup, oil pump etc etc, i did 3 oil services in one week using different oils to see if it would stop the tapping, hence the first question. 5w-30 and mine would sound tappy cold and hot, 10-40 and it was only when hot. Im now in the process of changing my head.
    Last edited: Jun 22, 2011
    #15
  17. Ryan360
    Offline

    Ryan360 Member

    Joined:
    Sep 12, 2010
    Messages:
    38
    Likes Received:
    0
    [Jun 22, 2011]
    No not really from cold, probably slightly tappier when warm, and SOMETIMES does tap quite loud after a little thrashing, but not very often.

    Nah i haven't, next time it does it i will try, my mate recon'd it was the tappets? But tbh im not sure.

    Oh ryt i used 10w40 cos its abit thicker and my car is on 150k.
    #16
  18. Lee172
    Offline

    Lee172 GT3071

    Joined:
    Jul 20, 2010
    Messages:
    431
    Likes Received:
    2
    [Jun 22, 2011]
    I dont think your engine has tappets. If its coming from the right hand side of your engine it would point more towards cam chain tensioner, anywhere else it would point towards hydraulic lifters (if it is a top end rattle). BUT, i would probably rule out the oil pump first.
    #17
  19. Ryan360
    Offline

    Ryan360 Member

    Joined:
    Sep 12, 2010
    Messages:
    38
    Likes Received:
    0
    [Jun 22, 2011]
    Oh ryt, ill have a good listen next time it does it. So yes looks like i will have to try the oil pump, i changed the oil pickup pipe around a month ago, is the pump a much harder job? or pretty straight forward, any specific tools i need?
    #18
  20. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    729
    [Jun 22, 2011]
    I would stop driving it until it is sorted, what milage out of interest?
    #19
  21. Lee172
    Offline

    Lee172 GT3071

    Joined:
    Jul 20, 2010
    Messages:
    431
    Likes Received:
    2
    [Jun 22, 2011]
    No just take the sump off, there will be 3 10mm bolts to undo the oil pump, i found if you tilt the pump to an angle it comes away from the chain easier. There is also a tensioner inbetween the pump and side of the engine that you can push back to give some more slack if needed. Thats how it was on my engine, im assuming yours will be the same. May be worth getting a new oil pick up pipe again too.

    Mileage is 150k dave
    Last edited: Jun 22, 2011
    #20
  22. Ryan360
    Offline

    Ryan360 Member

    Joined:
    Sep 12, 2010
    Messages:
    38
    Likes Received:
    0
    [Jul 3, 2011]
    Right ive fixed the problem guys. I cant actually believe what the real problem was all this time lol.

    Basically, i accidently filled the oil above max yesterday, not too much about a cm, anyway drove it that night and i noticed oil pressure light did not come on atall all night.. i thought this was abit strange.
    Today i was having a look in the engine bay and i noticed the oil dipstick housing was corroded and there was bits of metal missing of the top of it. What in fact had happened was my dipstick has been sitting too low this whole time, and saying the sump had max oil when really it was on min (as the dipsick seated around an inch lower then it should). What i suspect was happening is when i went round corners the oil that was in the sump pan was being sloshed over to one side of the pan and the oil pickup pipe was in the air for a few seconds not getting the oil needed!
    Also come to think of it when i first done a oil change on the car i noticed it didn't seem to take as much oil as it should but didn't think that much of it as it was up to max on the dipstick (was in fact just about on min)
    Soo ive now filled the oil up to 'max' and no oil pressure warning comes up what so ever :D
    I just cant believe it was something this simple, but very strange. I just hope the damage on my engine hasn't already been done!! :/
    (if only i had a oil level sensor!!)
    #21
  23. superkarl
    Offline

    superkarl MAN OF STEEL

    Joined:
    Mar 28, 2010
    Messages:
    7,614
    Likes Received:
    1,102
    [Jul 3, 2011]
    Excellent news. Hopefully there was no damage, as it is a killer. Just keep your ear on it and be careful
    #22
  24. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    729
    [Jul 4, 2011]
    Good work Ryan...
    #23
  25. Ryan360
    Offline

    Ryan360 Member

    Joined:
    Sep 12, 2010
    Messages:
    38
    Likes Received:
    0
    [Jul 4, 2011]
    Cheers :) Anyone know where i can get a replacement oil dipstick housing/funnel?
    #24
  26. superkarl
    Offline

    superkarl MAN OF STEEL

    Joined:
    Mar 28, 2010
    Messages:
    7,614
    Likes Received:
    1,102
    [Jul 4, 2011]
    Audi only i think. Hopefully someone has a part no for you.
    #25
  27. Ryan360
    Offline

    Ryan360 Member

    Joined:
    Sep 12, 2010
    Messages:
    38
    Likes Received:
    0
    [Jul 4, 2011]
    #26

Share This Page