1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

oil light

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by dec1579, Mar 9, 2013.

  1. dec1579
    Offline

    dec1579 New Member

    Joined:
    Sep 16, 2012
    Messages:
    7
    Likes Received:
    0
    hi all
    my oil light is coming on in my computer on my a4 their is plenty of oil in it just woundering dose any know what might be the problem or can help me out
    cheers dec
    #1
  2. gen.heinz guderian
    Offline

    gen.heinz guderian Well-Known Member

    Joined:
    Jun 24, 2011
    Messages:
    1,359
    Likes Received:
    125
    Are there 3 beeps when you turn ignition on? Could be oil pickup in Sump sludged up
    #2
  3. chrisa4quat
    Offline

    chrisa4quat Member

    Joined:
    Sep 21, 2004
    Messages:
    897
    Likes Received:
    10
    Red or yellow?
    #3
  4. duffy78
    Offline

    duffy78 Member

    Joined:
    Mar 26, 2012
    Messages:
    188
    Likes Received:
    5
    If it's a 1.8t you need to have a read about sludge and how it affects the pick up pipe in the sump.
    #4
  5. Isaa
    Offline

    Isaa Member

    Joined:
    Aug 12, 2012
    Messages:
    108
    Likes Received:
    23
    Hi mate I've just done a post on this same problem but now I need a whole new engine because the oil pump stopped working thus the engine receiving insufficient oil. I would advise you to sort it out ASAP.
    #5
  6. dec1579
    Offline

    dec1579 New Member

    Joined:
    Sep 16, 2012
    Messages:
    7
    Likes Received:
    0
    nope just beeps once and stays on and then the jug stays on
    #6
  7. dec1579
    Offline

    dec1579 New Member

    Joined:
    Sep 16, 2012
    Messages:
    7
    Likes Received:
    0
    its just the yellow jug
    #7
  8. dec1579
    Offline

    dec1579 New Member

    Joined:
    Sep 16, 2012
    Messages:
    7
    Likes Received:
    0
    nope just beeps once and stays on and then the jug stays on
    #8
  9. dec1579
    Offline

    dec1579 New Member

    Joined:
    Sep 16, 2012
    Messages:
    7
    Likes Received:
    0
    its the 2Ltdi
    #9
  10. dec1579
    Offline

    dec1579 New Member

    Joined:
    Sep 16, 2012
    Messages:
    7
    Likes Received:
    0
    cheers will get it sorted straight away some lads saying it could be the oil pressure sensor
    #10
  11. chrisa4quat
    Offline

    chrisa4quat Member

    Joined:
    Sep 21, 2004
    Messages:
    897
    Likes Received:
    10
    Oil pressure is red so won't be pressure sensor I wouldn't have thought. Could be bonnet catch or oil level sensor or just has used a bit of oil as daft as it sounds
    #11
  12. Paul B7
    Offline

    Paul B7 Active Member

    Joined:
    Feb 15, 2010
    Messages:
    610
    Likes Received:
    33

    Could be the Oil Pump/Balance shaft issue as its the 2.0 tdi ?
    #12
  13. countax
    Offline

    countax New Member

    Joined:
    Jun 5, 2012
    Messages:
    14
    Likes Received:
    1
    dec1579, can you please give us a bit more information on the engine type and how many miles you have on the clock. The engine type is on a sticker on the engine and also in the spare wheel well in the boot. It will be something like BLB, BPW etc.
    The 2.0L Tdi has a history of oil pump failure and it would be useful to know how many miles your car has covered before this fault occurred.
    There is a company called Powermax in Ireland that sell a fix to this problem if its the balance shaft drive to the oil pump that has failed on your car.
    Nigel
    #13
  14. chrisa4quat
    Offline

    chrisa4quat Member

    Joined:
    Sep 21, 2004
    Messages:
    897
    Likes Received:
    10
    Won't be balance shaft/oil pump. It's yellow warning light which is oil level
    #14
  15. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    It will be the sensor on the bottom of the sump most likely. Had the same issue with mine a few months back
    That's if it's the amber light
    #15
  16. dec1579
    Offline

    dec1579 New Member

    Joined:
    Sep 16, 2012
    Messages:
    7
    Likes Received:
    0
    hey lads
    i rang a mate of mine today who works with audi and he said to disconnect the battery so did that left it off for while and it seems to have cleared the problem lets hope it stays away thanks foe the help will put up pictures of the car later

    dec
    #16
  17. Paul B7
    Offline

    Paul B7 Active Member

    Joined:
    Feb 15, 2010
    Messages:
    610
    Likes Received:
    33
    Useful tip , thanks for the posting .
    #17
  18. chrisa4quat
    Offline

    chrisa4quat Member

    Joined:
    Sep 21, 2004
    Messages:
    897
    Likes Received:
    10
    See how you go. Hope it sorts it. Did you try leaving bonnet open for approximately 30 seconds?
    #18
  19. Paul B7
    Offline

    Paul B7 Active Member

    Joined:
    Feb 15, 2010
    Messages:
    610
    Likes Received:
    33
    Why would leaving the bonnet open for the said 30 seconds work ?
    #19
  20. chrisa4quat
    Offline

    chrisa4quat Member

    Joined:
    Sep 21, 2004
    Messages:
    897
    Likes Received:
    10
    Cos the bonnet switch is the reset button basically. To reset oil light after filling car has to have realised bonnet has been opened.
    #20
  21. Paul B7
    Offline

    Paul B7 Active Member

    Joined:
    Feb 15, 2010
    Messages:
    610
    Likes Received:
    33

    Thanks for the advice .
    #21

Share This Page