1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Oil level waring keeps coming on

GeoffDunk May 31, 2013

  1. GeoffDunk

    GeoffDunk Well-Known Member Team Panther Audi RS4 quattro Audi Avant Owner Group

    1,296
    384
    83
    Has anyone experienced this problem?

    2003 S4 103k miles, every now and then the oil level icon pops up on the DIS but I check the oil and it's at an acceptable level. Once checked the icon disappears.

    Has anyone else experienced or have any good ideas? I know these motors use oil so I am always nervous about the oil level and this isn't helping.

    cheers
     
  2. Az

    Az Hard slammed!

    1,023
    34
    48
    I wouldn't worry too much about it. I had the same problem with mine a few years back, it was intermittent but quite frequent, and like you say I'd check the oil level and it was fine. So had it checked out at a vag specialist and they traced it to some damaged wiring close to the oil level sensor. They stripped back the wiring and replaced it with fresh wires and I've not had the warning come back on since. Either that or it could be a faulty sensor.

    One thing I would say though, is that the red oil can warning on the DIS can also mean oil pressure, so it might be worth having the oil pressure tested, the vag specialists who did mine mentioned this to me and carried out a pressure test which came back fine luckily, but it might be worth having it checked out too.
     
  3. madmike01uk

    madmike01uk Member

    430
    21
    18
    Is it definitely level and not pressure?
     
  4. Az

    Az Hard slammed!

    1,023
    34
    48
    In the owners manual it says to initially check the oil level when the warning displays, then if the level is ok but the warning remains to take it to an Audi dealership. But as said, it also doubles as an oil pressure warning. Low oil level goes hand in hand with low oil pressure anyway hence why the manual says to initially check the oil level.
     
  5. dualmono21

    dualmono21 Well-Known Member VCDS Map User

    1,132
    82
    48
    is it the yellow warning or the red warning ???
    yellow is oil level warning
    red is oil pressure

    if it is red do not drive the car until you have had it checked out
    have a look behind the back of the oil filter on top of the engine about 3 or 4 inches down is the oil pressure switch
    it should have a single wire connection
    you could change the oil pressure switch as it should only be a few quid
    if your still getting the red warning after changing the switch then you need to do a manual check of the oil pressure
    remove the oil pressure switch and insert a manual or digital pressure gauge into the thread for the oil pressure switch and post up what your getting
    if this doesnt cure it then youll need vcds there are a couple of settings which can sometimes default to 0 which can give trouble

    if its yellow and keeps coming back up the sensor could have been damaged by turning the igntition on without any oil in the sump
    the sensor is in the sump of the car
     
  6. BRILLO

    BRILLO Member

    140
    7
    18
    My mate had this problem on his s4. I changed the sensor in the sump and been ok since.
     
  7. colinurquhart

    colinurquhart Member

    203
    34
    16
    Was the sensor hard to change and expensive?
     
  8. GeoffDunk

    GeoffDunk Well-Known Member Team Panther Audi RS4 quattro Audi Avant Owner Group

    1,296
    384
    83
    Thanks all for you info.

    The warning is the yellow "min level" indicator, never seen the red. I had the sensor changed a few months ago as this has been going on for sometime. I'll get my guy to check it again and check the wiring condition. Also get him to do an oil pressure check at the same time.

    Has anyone had this issue and had it connected to the breather pipe, or does anyone know of any issues with the breather on the v8, i have heard of issues with other breather pipes on other motors?

    chrs
     
  9. BRILLO

    BRILLO Member

    140
    7
    18
    its easy to change once you have the under tray off. Just 2 bolts and a gasket. Think it was £60 or £80 pound from Audi
     
  10. GeoffDunk

    GeoffDunk Well-Known Member Team Panther Audi RS4 quattro Audi Avant Owner Group

    1,296
    384
    83
    yes, when i had mine replaced it was £74.90, just checked the bill.
     
  11. colinurquhart

    colinurquhart Member

    203
    34
    16
    Cheers guys
     

Share This Page