1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Oil level sensor problem ?

Discussion in 'Audi S4/A4/A4 Cab (B8 Chassis)' started by luis.filipe, Jun 15, 2009.

  1. luis.filipe
    Offline

    luis.filipe Member

    Joined:
    Jul 30, 2007
    Messages:
    85
    Likes Received:
    0
    [Jun 15, 2009]
    Hi,

    when I try to "read" the oil level on the MMI sometimes I get a message like this:

    "The MMI displayed a message stating that it was unable to display the oil level information at this time."

    The engine is warmed at the service temperature and I try to read the oil level exactly has is written on the manual.

    Does anyone have a idea about this ?

    Another question, is that if I try to measure the oil level on the same place and following the same procedure I get different readings . . .:wtf:
    #1
  2. Ads

    Ads

    [Oct 26, 2014]

  3. luis.filipe
    Offline

    luis.filipe Member

    Joined:
    Jul 30, 2007
    Messages:
    85
    Likes Received:
    0
    [Jan 10, 2010]
    #2
  4. johnnythepie
    Offline

    johnnythepie Well-Known Member

    Joined:
    Apr 27, 2009
    Messages:
    2,219
    Likes Received:
    68
    [Jan 10, 2010]
    I had the same problem as luis.Took 10 days before i could get a reading.So off to the dealers (I live there) to get myself an advanced piece of technical equipment called a dipstick.But they dont make one for my 2ltr tdi.Bugger.How daft is that?Trust the MMI i dont think so.
    #3
  5. luis.filipe
    Offline

    luis.filipe Member

    Joined:
    Jul 30, 2007
    Messages:
    85
    Likes Received:
    0
    [Mar 2, 2010]
    During the last few miles, I continue with the same problem, sometimes I get a reading, then during a week or two I'm not able to check the oil level . . .
    Meanwhile I'm with 12 700 miles no oil warning light came on, which might be good or not, I guess that on the next couple of days the car will go to the dealers, at least I'll have a piece of paper statint that everything is ok . . . Let's wait and see
    #4
  6. DavyBoy
    Offline

    DavyBoy HardShoulder

    Joined:
    Mar 20, 2010
    Messages:
    7
    Likes Received:
    0
    [Mar 20, 2010]
    I have had the same problem on mine, i noticed whenever i take the filler cap off, i get the error message for a couple of hours, makes refilling a bit of a nightmare

    DavyBoy :think:
    #5
  7. DavyBoy
    Offline

    DavyBoy HardShoulder

    Joined:
    Mar 20, 2010
    Messages:
    7
    Likes Received:
    0
    [Mar 24, 2010]
    mine has now decided to say " Drain Some Oil" which is odd as i have not added any, the dealer has it booked in for the sensor to be replaced - 5 Day old 2.0 TDi

    DavyBoy:unsure:
    #6
  8. tettalep
    Offline

    tettalep New Member

    Joined:
    Jan 14, 2011
    Messages:
    1
    Likes Received:
    0
    [Jan 14, 2011]
    I bought brand new A4 2.0T. the MMI started reading less oil level after about 2500KM then it showed minimum on 4000KM. I took the car to the dealer which kept saying this is normal unil the expert saw the car and was worried the consumption is more than usual. They toped the oil up and said i have to watch it as they cant measure the consumption before 5000KM. after two days only the MMI read the oil level less than the max by a very small amount. I parked the car for one day and when i started it again the MMI showed empty oil but no light came on the dash board.I switch off the car then on again, i got the message "there is no information about engine oil level" car now is on 4000 KM but what worries me is that one week after i toped it up the MMI reads empty. Is that oil problem or MMI reads wrong? help me please in this..
    #7
  9. Zafi
    Offline

    Zafi Active Member

    Joined:
    Nov 28, 2010
    Messages:
    431
    Likes Received:
    50
    [Jan 15, 2011]
    I think that message means it IS time to add oil. The motor is not literally empty of oil ;)
    #8
  10. Zafi
    Offline

    Zafi Active Member

    Joined:
    Nov 28, 2010
    Messages:
    431
    Likes Received:
    50
    [Jan 15, 2011]
    I have a 2010 2.0 TDI bought a dipstick off an earlier B8 2.0 TDI, but it is too long.... the dipstick tube was longer on the earlier car.

    If you measure the Audi workshop tool its about 497 to high mark, 522 to low mark.

    A VW Passat 1.6 bluemotion has a dipstick that is pretty much those dimensions, but the thick part under the collar at the top is slightly different to the A4 blank, its as if the dipsticks are coded by having vanes on the top in different places.

    So I am going to buy a VW one and grind the vane off the collar..... cos the guy I borrowed the dipstick off would not let me grind his ;)
    #9
  11. Stevej69
    Offline

    Stevej69 New Member

    Joined:
    Dec 31, 2005
    Messages:
    11
    Likes Received:
    0
    [Apr 22, 2011]
    did anyone ever get a conclusion on this?
    #10

Share This Page