1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

oil level sensor faulty ?

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by mm707, Oct 6, 2012.

  1. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    250
    Likes Received:
    6
    hi,

    My oil level warning light keeps coming on despite the oil level being on just about max.

    Hopefully it's a faulty sensor - anyone changed one of these and is it a difficult job ?

    I'm planning on changing the oil in the next week or two also.

    Thanks

    2.0 TDI 170 2007
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. CHEZ

    CHEZ moderately amusing
    Supporter

    Joined:
    Jul 9, 2011
    Messages:
    3,830
    Likes Received:
    579
    is it the yellow level warning or the red warning?
     
  4. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    250
    Likes Received:
    6
    it's yellow warning light
     
  5. CHEZ

    CHEZ moderately amusing
    Supporter

    Joined:
    Jul 9, 2011
    Messages:
    3,830
    Likes Received:
    579
    if your due a service anyway, personally i would monitor it after the oil change imo.
    it could be that the oil is a bit thin and dirty, and possibly low as the dip sticks on these are a nightmare to read! :wtf:
    i would put tippex on your dip stick and check the level against the white of the tippex as it might be actually low!
    if low, remember its only 500ml between min and max so dont overfill! :rolleyes:
    remember also, oil consumption is normal (as long as not excessive) and regular top ups are needed on these engines as they dont hold much oil!
    a couple of times mine has flashed yellow so i always carry some oil in the boot!
    its when it flashes red when you need to worry about mate! and stop the engine straight away! and call the AA!
     
  6. i_786_i

    i_786_i Member

    Joined:
    Aug 9, 2012
    Messages:
    61
    Likes Received:
    3
    Hi,

    I have a B7 2.0TDI 2006 and had to replace my sensor 5months ago. Oil Min sensor displays after a while driving, lifting the bonnet will reset, but will display again after few miles (I wrote an article here about this)

    Check the dipstick to confirm - if oils fine then most likely sensor is faulty. Easy to replace (located on sump pan near sump nut) - ideally replaced when changing oil.

    5months later - no error again and no loss of oil either :)
     
  7. Luke2.0tdi2010

    Luke2.0tdi2010 Active Member

    Joined:
    Oct 19, 2012
    Messages:
    260
    Likes Received:
    42
    Yep, I've had the same problem on my 2.0 a4 avant '06, just replaced it last Wednesday, very very easy to replace however like someone else said you would probly wanna combine it with a service/oil change as you will need to drop all your oil to replace it.
    touch wood all seems to be fine so far!
    good luck
     

Share This Page